Bug 733679

Summary: Need better documentation of the ICICLE and deployable XML
Product: [Retired] CloudForms Cloud Engine Reporter: Chris Lalancette <clalance>
Component: Community WebsiteAssignee: Dan Macpherson <dmacpher>
Status: CLOSED CURRENTRELEASE QA Contact: wes hayutin <whayutin>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 1.0.0CC: akarol, cpelland, dajohnso, deltacloud-maint, dgao, dmacpher, hbrock, jclift, morazi, rlandy, ssachdev
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-13 19:49:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Chris Lalancette 2011-08-26 13:37:06 UTC
Groups outside of the Cloud Engine team are starting to look at integration, and they really need to know the formats of the various XML documents that we are using.  The TDL is fairly well documented in several places, but the ICICLE and deployable XML are much less so.  We need to improve this so that others can discover the documentation without looking at the Cloud Engine source code.

Comment 1 wes hayutin 2011-09-28 16:38:24 UTC
making sure all the bugs are at the right version for future queries

Comment 3 wes hayutin 2012-01-12 16:52:58 UTC
adding to sprint tracker

Comment 4 Hugh Brock 2012-01-18 19:38:23 UTC
Moving this provisionally to Ian. Ian, if there's someone else who deserves this BZ more than you, please send it their direction.

--H

Comment 5 Dan Macpherson 2012-01-26 16:10:38 UTC
I think I can write something for ICICLE and deployable XML this week.

Comment 6 Hugh Brock 2012-02-03 15:50:35 UTC
Updating severity to "medium", docs issues do not meet the high severity criteria.

Comment 8 Dan Macpherson 2012-04-09 23:31:20 UTC
Changing this to Community Website as this deals more with the upstream release than the enterprise docs.

Comment 9 Ronelle Landy 2012-09-28 15:23:23 UTC
Verified that the documentation exists in the aeolus wikis linked in Comment 7 above.

Since this is marked as a 'Community Website' BZ, verifying the BZ with this info.