Bug 733699

Summary: LINKDELAY not respected anymore
Product: [Fedora] Fedora Reporter: Marcus Moeller <marcus.moeller>
Component: systemdAssignee: Lennart Poettering <lpoetter>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: harald, johannbg, kay, lpoetter, metherid, mschmidt, notting, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-27 07:54:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marcus Moeller 2011-08-26 14:34:42 UTC
Description of problem:

I have set LINKDELAY=20 in /etc/sysconfig/network-scripts/ifcfg-eth0 as described in /usr/share/doc/initscripts-9.03.23/sysconfig.txt but it does not seem to be respected anymore.

Comment 1 Bill Nottingham 2011-08-26 15:19:45 UTC
In what way is it not respected? Are you using the network script or NetworkManager?

Comment 2 Marcus Moeller 2011-08-26 18:39:57 UTC
I am using classic network scripts (not nm). There is simply no delay between link setup and dhcp ip retreaval.

Comment 3 Bill Nottingham 2011-08-26 21:28:38 UTC
LINKDELAY for dhcp is the length of time it will wait for a link to show up - if it shows up, it will exit out sooner. That behavior has not changed.

Comment 4 Marcus Moeller 2011-08-27 07:54:21 UTC
Ok, then I just got it wrong. Sorry for the noice.