Bug 733788

Summary: Kernel panic when copying files from an external hard drive (FAT and NTFS)
Product: [Fedora] Fedora Reporter: Newfie <michaelneil.nfld>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: aquini, dennis, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-01 06:51:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Newfie 2011-08-26 21:00:13 UTC
I first used unetbootin on Fedora 15 (64 bit) to create a live USB for Fedora 16, also 64 bit. I booted the Live USB on my computer and it functions just fine. However, when I mount a second USB drive and try to copy files from it (tried with a FAT and NTFS drive) to the Fedora 16 live USB session, I get a kernel panic. The file transfer works fine until near the end; this is when the screen turns black and some errors pop up in a TTY followed by "kernel panic". Just for clarification, F16 has not been installed and this is entirely on a live USB. I have remade the F16 USB image on 2 different machines (running different distros) and on 3 USB drives; all have the same result, and the panic occurs on both of my computers.


Using the Live CD image of Fedora 16 Alpha x86_64 as advertised on Fedora's main page.


Reproduction is 100% consistent for me.


Steps to Reproduce:
1. Create a Fedora 16 live USB image.
2. Boot and log in to the F16 live session.
3. Mount a usb drive (thumb drive, etc)
4. Copy any file from the USB drive to any directory on F16.
5. Wait for panic.
  
Actual results: Kernel panic


Expected results: Should just copy the file(s).

Thanks, and good luck.

Comment 1 Josh Boyer 2011-08-27 13:19:57 UTC
Can you post the panic message including the full backtrace?  If the machine is unresponsive and you can't use it to attach dmesg, using a camera to take a picture of the panic on the screen can help.

Comment 2 Newfie 2011-08-27 15:23:05 UTC
There's a weird thing going on right now; I can't seem to reproduce the panic.

When I was trying this yesterday, I was repeatedly attempting to copy some files over just so I could test stuff out on Nouveau. Each and every time there was a kernel panic. Yet right now, everything is copying just fine. These are the same USB drives and machines as I was using before; no idea why it's suddenly working, especially since it's a live session without persistence.

Comment 3 Chuck Ebbert 2011-09-01 06:51:46 UTC
Closing as NOTABUG; you can reopen this bug if it starts happening again.