Bug 733928

Summary: please rebuild libtool with GCC 4.6.1
Product: [Fedora] Fedora Reporter: Harald Reindl <h.reindl>
Component: libtoolAssignee: Karsten Hopp <karsten>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: gryt2, karsten, rhbugs, robert.swain
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-29 22:08:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Harald Reindl 2011-08-28 17:32:16 UTC
currently GCC 4.6.1 is in updates-testing

on local build-machines the update fails because libtool requires GCC 4.5.0 
please rebuild it for 4.6.1, i did this today on my test-buildmachine and currently all my local maintained packages are rebuilt with GCC 4.6..1

Comment 1 Robert Swain 2011-08-29 06:11:20 UTC
It seems libtool has been built against GCC 4.6.1 in F16 but not F15. This lack of an update in F15 is blocking update of GCC.

Comment 2 Harald Reindl 2011-08-29 07:01:52 UTC
what does mean "it seems" and "blocks"?

[root@testserver:~]$ rpm -qa | grep libtool
libtool-ltdl-2.4-4.fc15.rh.20110828.x86_64
libtool-2.4-4.fc15.rh.20110828.x86_64
libtool-ltdl-devel-2.4-4.fc15.rh.20110828.x86_64

[root@testserver:~]$ rpm -qa | grep gcc
gcc-4.6.1-8.fc15.x86_64
gcc-gfortran-4.6.1-8.fc15.x86_64
libgcc-4.6.1-8.fc15.x86_64
gcc-c++-4.6.1-8.fc15.x86_64
gcc-java-4.6.1-8.fc15.x86_64

Comment 3 Robert Swain 2011-08-29 07:10:06 UTC
The current libtool package in F15 has a hard dependency on GCC 4.6.0. GCC has been updated to 4.6.1 but the packages cannot be upgraded if one has libtool installed because of the hard dependency on GCC 4.6.0. The libtool package in F16 has its dependency on GCC 4.6.1.

How is this normally resolved for libtool?

Comment 4 Harald Reindl 2011-08-29 08:56:54 UTC
i don't know, but i guess libtool should be rebuilt with the new deps and pushed to updates-testing at the same time as GCC what did not happen, so currently "updates-testing" is broken while all works fine, this is only a dep-problem

Comment 5 stan 2011-08-29 19:08:47 UTC
Here's the error I just received while trying to update on F15.

Error: Package: libtool-2.4-4.fc15.x86_64 (@/libtool-2.4-4.fc15.x86_64)
           Requires: gcc = 4.6.0
           Removing: gcc-4.6.0-10.fc15.x86_64 (@updates-testing)
               gcc = 4.6.0-10.fc15
           Updated By: gcc-4.6.1-8.fc15.x86_64 (updates-testing)
               gcc = 4.6.1-8.fc15
           Available: gcc-4.6.0-6.fc15.x86_64 (fedora)
               gcc = 4.6.0-6.fc15

Comment 6 Karsten Hopp 2011-08-29 22:08:58 UTC
new libtool-2.4-6.fc15 is on its way to f15-updates-testing