Bug 734660

Summary: OSError: Cannot call rmtree on a symbolic link
Product: [Fedora] Fedora Reporter: itam1212
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: anaconda-maint-list, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: anaconda_trace_hash:ca7aef79cf30307bc557b8d460b6f92114fdf2190be70964d73ebde807fa45c0
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-09 19:27:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Attached traceback automatically from anaconda. none

Description itam1212 2011-08-31 05:15:01 UTC
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/shutil.py", line 227, in rmtree
    raise OSError("Cannot call rmtree on a symbolic link")
  File "/usr/lib/python2.7/shutil.py", line 229, in rmtree
    onerror(os.path.islink, path, sys.exc_info())
  File "/usr/lib/python2.7/site-packages/pyanaconda/livecd.py", line 268, in _doFilesystemMangling
    shutil.rmtree("%s/%s" % (anaconda.rootPath, tocopy))
  File "/usr/lib/python2.7/site-packages/pyanaconda/livecd.py", line 315, in doPostInstall
    self._doFilesystemMangling(anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 205, in doPostInstall
    anaconda.backend.doPostInstall(anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1278, in handleRenderCallback
    self.currentWindow.renderCallback()
OSError: Cannot call rmtree on a symbolic link

Comment 1 itam1212 2011-08-31 05:15:06 UTC
Created attachment 520739 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2011-09-05 19:21:09 UTC
Is this still a problem with F16?

Comment 3 itam1212 2011-09-05 23:40:37 UTC
I dont know if this is a problem or user error. 
Happened to me while I tried an LVM with /home/ on another physical 
drive. eventually I did standard partitioning layout without LVM and that worked.