Bug 735154

Summary: ERROR with rpm_check_debug vs depsolve
Product: Red Hat Enterprise Linux 5 Reporter: M. Ellis <michael.ellis>
Component: yumAssignee: packaging-team-maint
Status: CLOSED NOTABUG QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.8CC: zpavlas
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-22 11:11:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description M. Ellis 2011-09-01 11:50:52 EDT
Description of problem:

While running yum update, yum throws the following error:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libsmbios is needed by (installed) smbios-utils-bin-2.2.19-4.1.el3.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Version-Release number of selected component (if applicable):


How reproducible:

Happens every time.

Steps to Reproduce:
1. Clean yum (to make sure nothing's outstanding)
2. Run yum update
3. Error produces itself.
  
Actual results:

Spits error

Expected results:

Clean yum update.

Additional info:
Comment 1 Zdeněk Pavlas 2013-03-22 11:11:57 EDT
Run: rpm -Va --nofiles --nodigest


...you'll probably find that it's a preexisting problem in the rpmdb,