Bug 735341

Summary: gnome-documents fails to start with "TypeError: account.get_id is not a function"
Product: [Fedora] Fedora Reporter: Michel Alexandre Salim <michel>
Component: gnome-documentsAssignee: Elad Alfassa <elad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 16CC: ccecchi, davidz, elad
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-documents-0.1.90-2.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-07 03:38:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch for "account.get_id is not a function" error
none
Patch for "account.get_id is not a function" error
none
Updated and tested patch none

Description Michel Alexandre Salim 2011-09-02 12:32:57 UTC
Description of problem:
On Fedora 16, both gnome-documents 0.1.90 and Git master fails to start with the following exception. It seems that account.get_id is null, for some reason.

With the RPM (from Koji):
=========================
    JS ERROR: !!!   Exception was: Error: Could not locate tracker_sparql_connection_new: `tracker_sparql_connection_new': /usr/lib64/libtracker-sparql-0.12.so: undefined symbol: tracker_sparql_connection_new
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = '"gjs_throw"'
    JS ERROR: !!!     stack = '"("Could not locate tracker_sparql_connection_new: `tracker_sparql_connection_new': /usr/lib64/libtracker-sparql-0.12.so: undefined symbol: tracker_sparql_connection_new")@gjs_throw:0
()@/usr/share/gnome-documents/js/application.js:126
("org.gnome.Documents")@/usr/share/gnome-documents/js/application.js:87
start()@/usr/share/gnome-documents/js/main.js:27
@<command line>:1
"'
    JS ERROR: !!!     message = '"Could not locate tracker_sparql_connection_new: `tracker_sparql_connection_new': /usr/lib64/libtracker-sparql-0.12.so: undefined symbol: tracker_sparql_connection_new"'
    JS ERROR: !!!   Exception was: TypeError: account.get_id is not a function
    JS ERROR: !!!     lineNumber = '51'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/sources.js"'
    JS ERROR: !!!     stack = '"([object Object])@/usr/share/gnome-documents/js/sources.js:51
Source([object Object])@/usr/share/gnome-documents/js/sources.js:38
([object _private_Goa_ObjectProxy],0,[object Array])@/usr/share/gnome-documents/js/sources.js:138
([object _private_Goa_Client],[object _private_Gio_SimpleAsyncResult])@/usr/share/gnome-documents/js/sources.js:129
start()@/usr/share/gnome-documents/js/main.js:27
@<command line>:1
"'
    JS ERROR: !!!     message = '"account.get_id is not a function"'

=========
From Git:
=========

    JS ERROR: !!!   Exception was: TypeError: account.get_id is not a function
    JS ERROR: !!!     lineNumber = '51'
    JS ERROR: !!!     fileName = '"/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/sources.js"'
    JS ERROR: !!!     stack = '"([object Object])@/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/sources.js:51
Source([object Object])@/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/sources.js:38
([object _private_Goa_ObjectProxy],0,[object Array])@/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/sources.js:144
([object _private_Goa_Client],[object _private_Gio_SimpleAsyncResult])@/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/sources.js:135
start()@/home/michel/opt/stow/gnome-documents/share/gnome-documents/js/main.js:27
@<command line>:1
"'
    JS ERROR: !!!     message = '"account.get_id is not a function"'


Version-Release number of selected component (if applicable):
gnome-documents-0.1.90-1.fc16.x86_64
gjs-1.29.17-1.fc16.x86_64
gnome-online-accounts-3.1.90-1.fc16.x86_64
gobject-introspection-1.29.17-1.fc16.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Elad Alfassa 2011-09-02 14:24:50 UTC
Maybe it's a bug in gnome-online-accounts. I don't have an f16 test machine yet so I couldn't test it myself. 
Thank you for reporting this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 David Zeuthen 2011-09-02 15:12:24 UTC
Pasting from IRC

<davidz> elad: that's probably caused by the fact that gdbus-codegen(1) now uses the (skip) annotation on generated C property getters

<davidz> cosimoc: it's better (and thread-safe, actually) to access the GObject property directly via e.g. account.id

Comment 3 Elad Alfassa 2011-09-02 16:17:21 UTC
Created attachment 521261 [details]
Patch for "account.get_id is not a function" error

So, it seems that there are two errors here. One is the account.id thing, the other seem to be tracker related.

What is the output of
rpm -q tracker

Does the attached patch fix the problem? if it doesn't, what's the output when running with this patch applied?

Comment 4 Elad Alfassa 2011-09-03 08:32:44 UTC
Please try this scratch build, does it fix the problem?
http://koji.fedoraproject.org/koji/taskinfo?taskID=3322276



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Michel Alexandre Salim 2011-09-03 10:13:39 UTC
(In reply to comment #3)
> Created attachment 521261 [details]
> Patch for "account.get_id is not a function" error
> 
> So, it seems that there are two errors here. One is the account.id thing, the
> other seem to be tracker related.
> 
> What is the output of
> rpm -q tracker
> 
tracker-0.11.2-1.fc16.x86_64, from updates-testing

> Does the attached patch fix the problem? if it doesn't, what's the output when
> running with this patch applied?
No -- account.id is not a function either!

    JS ERROR: !!!     message = '"Could not locate tracker_sparql_connection_new: `tracker_sparql_connection_new': /usr/lib64/libtracker-sparql-0.12.so: undefined symbol: tracker_sparql_connection_new"'
    JS ERROR: !!!   Exception was: TypeError: account.id is not a function
    JS ERROR: !!!     lineNumber = '51'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-documents/js/sources.js"'
    JS ERROR: !!!     stack = '"([object Object])@/usr/share/gnome-documents/js/sources.js:51
Source([object Object])@/usr/share/gnome-documents/js/sources.js:38
([object _private_Goa_ObjectProxy],0,[object Array])@/usr/share/gnome-documents/js/sources.js:138
([object _private_Goa_Client],[object _private_Gio_SimpleAsyncResult])@/usr/share/gnome-documents/js/sources.js:129
start()@/usr/share/gnome-documents/js/main.js:27
@<command line>:1
"'
    JS ERROR: !!!     message = '"account.id is not a function"'

Comment 6 Elad Alfassa 2011-09-03 10:14:41 UTC
Created attachment 521327 [details]
Patch for "account.get_id is not a function" error

Comment 7 Michel Alexandre Salim 2011-09-03 10:38:58 UTC
Created attachment 521328 [details]
Updated and tested patch

Comment 8 Fedora Update System 2011-09-03 11:16:19 UTC
gnome-documents-0.1.90-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-documents-0.1.90-1.fc16

Comment 9 Elad Alfassa 2011-09-03 11:22:13 UTC
The correct link is 
https://admin.fedoraproject.org/updates/gnome-documents-0.1.90-2.fc16



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Fedora Update System 2011-09-07 03:38:40 UTC
gnome-documents-0.1.90-2.fc16 has been pushed to the Fedora 16 stable repository.