Bug 735562

Summary: SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/autofs.
Product: [Fedora] Fedora Reporter: zxcv <Dietrich.Lolz>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:b0801908ad28b96f111ed66ff9bb4deec25e5c3d59dcaa3eed8866b8d8154904
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-05 06:12:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description zxcv 2011-09-03 15:05:05 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/autofs.
time:           Sat Sep  3 12:06:36 2011

description:
:SELinux is preventing /usr/bin/chfn from 'getattr' accesses on the chr_file /dev/autofs.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chfn should be allowed getattr access on the autofs chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chfn /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:chfn_t:s0
:Target Context                system_u:object_r:autofs_device_t:s0
:Target Objects                /dev/autofs [ chr_file ]
:Source                        chfn
:Source Path                   /usr/bin/chfn
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           util-linux-2.19.1-2.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sat 03 Sep 2011 10:39:48 AM CLST
:Last Seen                     Sat 03 Sep 2011 10:39:53 AM CLST
:Local ID                      a26a1ca2-1c62-4f52-9e3b-1bd2942f17f5
:
:Raw Audit Messages
:type=AVC msg=audit(1315057193.577:1307): avc:  denied  { getattr } for  pid=2245 comm="chfn" path="/dev/autofs" dev=devtmpfs ino=5867 scontext=unconfined_u:unconfined_r:chfn_t:s0 tcontext=system_u:object_r:autofs_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1315057193.577:1307): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fffd89b96d0 a1=7fffd89b4fa0 a2=7fffd89b4fa0 a3=0 items=0 ppid=2214 pid=2245 auid=1000 uid=1000 gid=1000 euid=0 suid=0 fsuid=0 egid=1000 sgid=1000 fsgid=1000 tty=pts1 ses=2 comm=chfn exe=/usr/bin/chfn subj=unconfined_u:unconfined_r:chfn_t:s0 key=(null)
:
:Hash: chfn,chfn_t,autofs_device_t,chr_file,getattr
:
:audit2allow
:
:#============= chfn_t ==============
:allow chfn_t autofs_device_t:chr_file getattr;
:
:audit2allow -R
:
:#============= chfn_t ==============
:allow chfn_t autofs_device_t:chr_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-05 06:12:44 UTC

*** This bug has been marked as a duplicate of bug 735556 ***