Bug 735564

Summary: SELinux is preventing /usr/bin/certwatch from 'getattr' accesses on the sock_file /run/pcscd.comm.
Product: [Fedora] Fedora Reporter: zxcv <Dietrich.Lolz>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:7084f8506fed2f615ce7ead8d240ab9585e98cb6c487d1db9340695a5b65d486
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-05 06:13:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description zxcv 2011-09-03 15:05:44 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/certwatch from 'getattr' accesses on the sock_file /run/pcscd.comm.
time:           Sat Sep  3 12:07:16 2011

description:
:SELinux is preventing /usr/bin/certwatch from 'getattr' accesses on the sock_file /run/pcscd.comm.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that certwatch should be allowed getattr access on the pcscd.comm sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep certwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                /run/pcscd.comm [ sock_file ]
:Source                        certwatch
:Source Path                   /usr/bin/certwatch
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           crypto-utils-2.4.1-31
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sat 03 Sep 2011 11:42:04 AM CLST
:Last Seen                     Sat 03 Sep 2011 11:42:04 AM CLST
:Local ID                      dc6b213b-0dbd-4932-be56-b5dbc9949890
:
:Raw Audit Messages
:type=AVC msg=audit(1315060924.603:87): avc:  denied  { getattr } for  pid=3194 comm="certwatch" path="/run/pcscd.comm" dev=tmpfs ino=12733 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1315060924.603:87): arch=x86_64 syscall=stat success=no exit=EACCES a0=7f7b1f2f6ca0 a1=7fffdb51b360 a2=7fffdb51b360 a3=7fffdb51b280 items=0 ppid=3189 pid=3194 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm=certwatch exe=/usr/bin/certwatch subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)
:
:Hash: certwatch,certwatch_t,var_run_t,sock_file,getattr
:
:audit2allow
:
:#============= certwatch_t ==============
:allow certwatch_t var_run_t:sock_file getattr;
:
:audit2allow -R
:
:#============= certwatch_t ==============
:allow certwatch_t var_run_t:sock_file getattr;
:

Comment 1 Miroslav Grepl 2011-09-05 06:13:31 UTC

*** This bug has been marked as a duplicate of bug 735556 ***

Comment 2 Miroslav Grepl 2011-09-05 06:48:56 UTC

*** This bug has been marked as a duplicate of bug 729997 ***