Bug 735869

Summary: NetCDF support not compiled on dx
Product: [Fedora] Fedora EPEL Reporter: Eduardo <ecruzs12>
Component: dxAssignee: Dominik 'Rathann' Mierzejewski <dominik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: el6CC: dominik
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: dx-4.4.4-11.el6.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-06 20:24:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Eduardo 2011-09-05 20:54:34 UTC
Description of problem:
When using the package as available on EPEL, netcdf support was not included at compile time.  

Version-Release number of selected component (if applicable):4.4.4-11.el6.2

Looking at the spec file, it is not called explicitly when running the configure utility, since it is a default option. Even after adding "--with-netcdf", the configure script can't find netcdf.h, as one of the patches (dx-rpm.patch, line 178) forces the configure script to look for the header file in /usr/include/netcdf/netcdf.h but for el6 this file is located in /usr/include/netcdf.h

Modifying this patch resolves the issue and netcdf support is compiled.

Comment 1 Fedora Update System 2011-10-12 10:24:44 UTC
dx-4.4.4-11.el6.3 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/dx-4.4.4-11.el6.3

Comment 2 Fedora Update System 2011-10-12 21:57:40 UTC
Package dx-4.4.4-11.el6.3:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing dx-4.4.4-11.el6.3'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-4686
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2011-11-06 20:24:01 UTC
dx-4.4.4-11.el6.3 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.