Bug 735956

Summary: Update request: uqm 0.7.0
Product: [Fedora] Fedora Reporter: Tomas Miljenović (TomasM) <TomasM>
Component: uqmAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: gwync, pizza
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: uqm-0.7.0-2.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-10 19:37:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Miljenović (TomasM) 2011-09-06 09:45:26 UTC
The Ur-Quan Masters 0.7.0 was released in July this year.  Fedora is currently shipping packages based on version 0.6.2, which had been the latest upstream version for four and a half years.

I had a problem with SDL includes when building this on Fedora 14 and 15:
https://bugs.uqm.stack.nl/show_bug.cgi?id=1142

This version has new content and addon directories (c.f. http://wiki.uqm.stack.nl/Content_Management).  I have a source rpm of a successful build at:
http://tomasm.tk/fedorarepo/TMM/SRPMS/uqm-0.7.0-0.3.TMM.fc15.src.rpm
Without some clever simlinking, an upgrade from a previous version may break user-installed addons like uqmremix/remix.

Some Fedora users have been playing 0.7.0-branch versions for a couple of months with no issues.  There is no change in gameplay or game experience (except for some bugfixes).

Comment 1 Solomon Peachy 2011-11-04 21:08:45 UTC
It's looking like UQM's been abandoned in Fedora..

I also did a F15 build of uqm 0.7.0:

http://www.shaftnet.org/users/pizza/uqm-0.7.0-1.fc15.src.rpm

It downloads all the correct content packs and even the remix packs.

Anyway..

Comment 2 Gwyn Ciesla 2011-11-09 18:32:34 UTC
No, I've just been busy.  I'll have a look shortly.

Comment 3 Fedora Update System 2011-11-17 17:45:46 UTC
uqm-0.7.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/uqm-0.7.0-1.fc16

Comment 4 Fedora Update System 2011-11-17 17:45:54 UTC
uqm-0.7.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/uqm-0.7.0-1.fc15

Comment 5 Fedora Update System 2011-11-19 06:03:49 UTC
Package uqm-0.7.0-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing uqm-0.7.0-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16122/uqm-0.7.0-1.fc15
then log in and leave karma (feedback).

Comment 6 Solomon Peachy 2011-11-22 20:20:22 UTC
The '3domusic' and 'voice' add-on packs are being placed in the wrong place.

Currently they're being downloaded to ~/.uqm/content/packages

This results in this output:

Loading resource index 'uqm.rmp'
Warning: Addon '3domusic' not found
Warning: Addon '3dovoice' not found
Loading resource index 'remix1.rmp'
Loading resource index 'remix2.rmp'
Loading resource index 'remix3.rmp'

They should go into ~/.uqm/content/addons instead, which results in:

Loading resource index 'uqm.rmp'
Loading resource index '3domusic.rmp'
Loading resource index '3dovoice.rmp'
Loading resource index 'remix1.rmp'
Loading resource index 'remix2.rmp'
Loading resource index 'remix3.rmp'

Once I moved the files to the right place, everything worked fine.

Comment 7 Gwyn Ciesla 2011-11-22 20:33:27 UTC
I'd have thought the symlink in uqm-functions.sh would catch that, or am I misunderstanding?

Comment 8 Solomon Peachy 2011-11-22 20:47:25 UTC
A from-scratch installation of the 0.7.0-1 package (with no ~/.uqm directory present) resulted in the game complaining about missing 3dovoice/3domusic packs.

The symlinks created aren't of any use at all with v0.7.0, from what I can tell.

Oh, and uqm-functions.sh uses 'uqm-0.6.2' as its canary file.

Comment 9 Tomas Miljenović (TomasM) 2011-11-24 12:36:57 UTC
I think there's been a mix-up over the addon download paths in uqm.autodlrc; they should be [PATH]$HOME/.uqm/content/addons[/PATH] and not point to a packages/ dir.

The symlink in uqm-functions.sh allows addons to be installed under /usr/share/uqm/$CONTENT_DIR and then appear in ~/.uqm/$CONTENT_DIR for each user.  However, uqm-0.7.0-1.fc15.rpm still links to and from old content directories (not that this affects where autodownloader places files).  It may be necessary to move third-party addons found under %{_datadir}/uqm/packages/addons to %{_datadir}/uqm/content/addons/ at the postinst stage, or (:P) update the release notes to inform users of the change.

Have the rmp files for the 3domusic and 3dovoice addons been included in the new package, or are they somehow auto-downloaded?  From comment #6 I'd guess so, but I can't see where...

I have sources for packages which have worked for me on fresh installs here:
http://tomasm.tk/fedorarepo/TMM/SRPMS/repoview/uqm.html
though some diff-fu may be required, as I've put in other changes since they were forked from uqm-0.6.2-11.fc14 (c.f. changelog).

I personally am not game to allow autodownloader to grab the remix discs, as I'm not certain of their license - apologies if that's already been sorted.  I'm sure some of the translation addons are appropriately licensed, though that's probably something for another bug to track.

Comment 10 Solomon Peachy 2011-11-24 14:31:22 UTC
Yeah, my modified SRPM downloaded everything into the right places too.  

The .rmp files are already inclued in the various content packs that are distributed from the uqm sourceforge download page.  There's no need to download them separately.

As for the remix pack licenses -- there's no explicit license anyhere that I can find, but they appear to be implicitly licensed the same as the UQM content (CC-BY-NC-SA) and may be "copied freely as part of a distribution of UQM".  Since the remixes are clearly derived from the original content, that would seem to be that.

Comment 11 Tomas Miljenović (TomasM) 2011-11-24 15:13:18 UTC
(In reply to comment #10)
> Yeah, my modified SRPM downloaded everything into the right places too.

uqm.autodlrc from http://kojipkgs.fedoraproject.org/packages/uqm/0.6.2/12.fc15/src/uqm-0.6.2-12.fc15.src.rpm (and http://www.shaftnet.org/users/pizza/uqm-0.7.0-1.fc15.src.rpm) still have (e.g.)

[FILENAME]uqm-0.7.0-3domusic.uqm[/FILENAME]
	[MD5]86a5e376d9b76888add1d10818f0ab9f[/MD5]
	[PATH]$HOME/.uqm/content/packages/addons[/PATH]

Maybe look for a newer version in your SOURCES dir and attach it?  Or `sed -e "s|content/packages/addons|content/addons|g"` on uqm.autodlrc and uqm-functions.sh should fix things.

> The .rmp files are already inclued in the various content packs that are
> distributed from the uqm sourceforge download page.  There's no need to
> download them separately.

Ah, thanks...

> As for the remix pack licenses -- there's no explicit license anyhere that I
> can find, but they appear to be implicitly licensed the same as the UQM content
> (CC-BY-NC-SA) and may be "copied freely as part of a distribution of UQM". 
> Since the remixes are clearly derived from the original content, that would
> seem to be that.

Glad they're being shipped now then; it was always a pain to get those manually.

Comment 12 Gwyn Ciesla 2011-11-28 14:42:00 UTC
So I'm lost now. :)  Do we need the autodl file patched, or are we good?

Comment 13 Solomon Peachy 2011-11-29 01:53:39 UTC
Yes, the autodl file in the proposed update needs patching.

I put up an updated srpm here:

http://www.shaftnet.org/users/pizza/uqm-0.7.0-1.fc16.src.rpm

It has an autodl file that puts everything into the correct places:

http://www.shaftnet.org/users/pizza/uqm.autodlrc

Comment 14 Gwyn Ciesla 2011-11-29 14:05:51 UTC
Cool, I'll get patched updates out for testing.

Comment 15 Fedora Update System 2011-11-29 14:23:03 UTC
uqm-0.7.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/uqm-0.7.0-2.fc16

Comment 16 Fedora Update System 2011-11-29 14:23:13 UTC
uqm-0.7.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/uqm-0.7.0-2.fc15

Comment 17 Solomon Peachy 2011-12-04 13:22:45 UTC
Just wanted to say that the 0.7.0-2 package worked great.

One minor niggling comment -- the launcher script creates and keys off the file ~/.uqm/uqm-0.6.2 -- It really should be  ~/.uqm/uqm-0.7.0. 

I just added a positive vote to the package, thanks for your work!

Comment 18 Fedora Update System 2011-12-10 19:37:03 UTC
uqm-0.7.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-12-10 20:06:04 UTC
uqm-0.7.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.