Bug 736374

Summary: Wifi in Kernel 2.6.40 causes my *router* to cease working. Was OK with 2.6.38
Product: [Fedora] Fedora Reporter: Yaniv Kaul <ykaul>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 15CC: gansalmon, itamar, jkt, jonathan, kernel-maint, madhu.chinakonda, sgruszka
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-08 15:04:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
hopefully some relevant messages from the system log none

Description Yaniv Kaul 2011-09-07 14:07:33 UTC
Description of problem:
When I boot into 2.6.40 kernel (updated some days ago), my Wifi card gets an IP from my home router (a dd-wrt firmware), then the router stops responding after several seconds.
Does not happen with a 2.6.38 kernel on my laptop, nor with the Windows 7 it has. Never happened to me with F14 of course or earlier F15 kernels.

Version-Release number of selected component (if applicable):
2.6.40.3-0.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot with kernel 2.6.40, wait for an IP from my router. 
2. Wait a few seconds (in which I actually have connectivity)
3. Boom - router's dead. A reboot is needed.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Kaul 2011-09-07 14:08:08 UTC
Created attachment 521901 [details]
hopefully some relevant messages from the system log

Comment 2 Yaniv Kaul 2011-09-07 14:09:10 UTC
Wifi card:
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
	Subsystem: Intel Corporation WiFi Link 5100 AGN
	Physical Slot: 1
	Flags: bus master, fast devsel, latency 0, IRQ 50
	Memory at f4300000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlagn
	Kernel modules: iwlagn


[ykaul@ykaul wireshark]$ modinfo iwlagn |grep -v alias
filename:       /lib/modules/2.6.40.3-0.fc15.x86_64/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:d
description:    Intel(R) Wireless WiFi Link AGN driver for Linux
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-5.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-105-5.ucode
firmware:       iwlwifi-2030-5.ucode
firmware:       iwlwifi-2000-5.ucode
srcversion:     9ADDCBAAD2A79D58AAE8494
depends:        cfg80211,mac80211
vermagic:       2.6.40.3-0.fc15.x86_64 SMP mod_unload 
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking (int)
parm:           no_sleep_autoadjust:don't automatically adjust sleep level according to maximum network latency (bool)
parm:           bt_coex_active:enable wifi/bluetooth co-exist (bool)
parm:           debug:debug output mask (uint)
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality (int)
parm:           amsdu_size_8K:enable 8K amsdu size (int)
parm:           fw_restart:restart firmware in case of error (int)
parm:           ucode_alternative:specify ucode alternative to use from ucode file (int)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           bt_ch_inhibition:Disable BT channel inhibition (default: enable) (bool)
parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
parm:           ack_check:Check ack health (default: 0 [disabled]) (bool)

Comment 3 Stanislaw Gruszka 2011-09-08 15:04:22 UTC
This should be "fixed" in kernel-2.6.40.4-5

Comment 4 Stanislaw Gruszka 2011-09-08 15:04:53 UTC

*** This bug has been marked as a duplicate of bug 708747 ***

Comment 5 Yaniv Kaul 2011-09-12 07:25:07 UTC
(In reply to comment #3)
> This should be "fixed" in kernel-2.6.40.4-5

Indeed it is. Thanks.