Bug 736770

Summary: [RFE] Promotion notifications go to the wrong session
Product: Red Hat Satellite 6 Reporter: Jeff Weiss <jweiss>
Component: WebUIAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED WONTFIX QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.0CC: bkearney, dajohnso, mmccune
Target Milestone: UnspecifiedKeywords: FutureFeature
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-08 19:10:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Weiss 2011-09-08 16:12:42 UTC
Description of problem:
When there are multiple browser sessions open for the same user, and a promotion fails with  "×Failed to promote: Cannot promote a changeset while another is being promoted." (or possibly with other notifs), the notification goes to the wrong session.  This only happens for async notifications.


<jsherrill> bbuckingham: jweiss  i think this issue is a lot simpler, i think
            we can just change synchronous_request to true on that one error
            message and be ok
<jsherrill> i think that will fix the bug

Version-Release number of selected component (if applicable):
katello-0.1.77-1.git.8.e67933c.fc14.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jason E. Rist 2012-12-19 18:55:12 UTC
Changing to an ehnacement - basically we will have to track notices with sessions to that we can respond to the right session with the right notice.  This will have to be a somewhat major rewrite of notifications as it stands now since they aren't tied to sessions at all.

Comment 3 Bryan Kearney 2014-09-08 19:10:48 UTC
Notifications are no longerused. i am closing this out. Please feel free to reopen if you disagree.