Bug 736777

Summary: Installer allows 'New Server' to use same name as existing server resulting in the existing server being removed
Product: [Other] RHQ Project Reporter: Larry O'Leary <loleary>
Component: InstallerAssignee: RHQ Project Maintainer <rhq-maint>
Status: NEW --- QA Contact: Mike Foley <mfoley>
Severity: high Docs Contact:
Priority: medium    
Version: 3.0.0CC: hrupp
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
JON 2.4.0
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Larry O'Leary 2011-09-08 12:31:23 EDT
Description of problem:
When installing a second server in an HA configuration, if the server name provided during installation is the same as an existing server, the affect is that the existing server no longer exists and its configuration is simply replaced by the new server.

Version-Release number of selected component (if applicable):
JON 2.4.0

How reproducible:
Always

Steps to Reproduce:
1. Install a JON server
2. Install a second JON server in HA configuration using the 'New server' option and the exact same "Server Name" as the first
  
Actual results:
From Administration -> High Availability -> Servers only the second server is shown

Expected results:
The installer should fail to proceed indicating that a server already exists with the specified name and either the Replace option should be used or a unique name should be given.