Bug 736791

Summary: Owner DELETE rest call needs url decoding to support unicode
Product: [Community] Candlepin Reporter: Shannon Hughes <shughes>
Component: candlepinAssignee: Bryan Kearney <bkearney>
Status: CLOSED CURRENTRELEASE QA Contact: John Sefler <jsefler>
Severity: low Docs Contact:
Priority: unspecified    
Version: 0.5CC: bkearney, jomara
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 674162 Environment:
Last Closed: 2011-12-02 20:48:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 674162    
Bug Blocks: 729111    

Description Shannon Hughes 2011-09-08 17:38:05 UTC
Katello is currently sending unicode to the Owner create which is working correctly since the actual key is part of the POST. When katello sends over url decoded restful paths (e.g. DELETE) candlepin can not find the matching owner key. It appears CP is not decoding the path.

Comment 1 James Bowes 2011-09-13 12:03:53 UTC
Fixed via an upgrade of RESTEasy. fix is in candlepin, 760776281a8549b048b5262cbc1ab5eae39ba9e9

Comment 2 James Bowes 2011-12-02 20:48:42 UTC
closing this out, its been done for a while