Bug 736972

Summary: SELinux is preventing ntpd from 'associate' accesses on the mémoire partagée Unknown.
Product: [Fedora] Fedora Reporter: panpan_du54
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: dominick.grift, dwalsh, mgrepl, panpan_du54
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:6e85a03c9627ebf2c26f34b412fe5d06950e7b0c391d0020261d06268296972c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-09 09:06:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description panpan_du54 2011-09-09 08:13:14 UTC
SELinux is preventing ntpd from 'associate' accesses on the mémoire partagée Unknown.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that ntpd should be allowed associate access on the Unknown shm by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ntpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ntpd_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                Unknown [ shm ]
Source                        ntpd
Source Path                   ntpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40-4.fc15.x86_64
                              #1 SMP Fri Jul 29 18:46:53 UTC 2011 x86_64 x86_64
Alert Count                   10
First Seen                    ven. 09 sept. 2011 09:02:25 CEST
Last Seen                     ven. 09 sept. 2011 10:08:04 CEST
Local ID                      5fe23376-e6c6-46ba-a782-be79bc779287

Raw Audit Messages
type=AVC msg=audit(1315555684.50:2624): avc:  denied  { associate } for  pid=542 comm="ntpd" key=839398080  scontext=system_u:system_r:ntpd_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=shm


Hash: ntpd,ntpd_t,initrc_t,shm,associate

audit2allow

#============= ntpd_t ==============
allow ntpd_t initrc_t:shm associate;

audit2allow -R

#============= ntpd_t ==============
allow ntpd_t initrc_t:shm associate;

Comment 1 Miroslav Grepl 2011-09-09 09:06:13 UTC

*** This bug has been marked as a duplicate of bug 736967 ***