Bug 736989

Summary: bkr distros-list throws SQL error
Product: [Community] Beaker Reporter: Tomas Kopecek <tkopecek>
Component: command lineAssignee: Dan Callaghan <dcallagh>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 0.7CC: bpeck, dcallagh, mcsontos, rmancy, stl
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-20 06:18:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 736075    

Description Tomas Kopecek 2011-09-09 09:19:16 UTC
bkr distros-list --treepath '%RHEL6.2-%' --tag STABLE --limit 1

returns:
XML-RPC fault: sqlalchemy.exceptions.InvalidRequestError:Select statement 'SELECT 1 
FROM distro, distro_lab_controller_map 
WHERE distro.id = distro_lab_controller_map.distro_id' returned no FROM clauses due to auto-correlation; specify correlate(<tables>) to control correlation manually.

Used rpms:
beaker-client-0.7.1-1.el5.noarch
beaker-0.7.1-1.el5.noarch

It is probably some regression. It was working some time ago, now I can't get any result with --treepath argument