Bug 737074

Summary: update request: hunspell 1.3.2
Product: [Fedora] Fedora Reporter: Reinout van Schouwen <reinouts>
Component: hunspellAssignee: Caolan McNamara <caolanm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 15CC: caolanm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-16 11:35:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Reinout van Schouwen 2011-09-09 14:13:49 UTC
Description of problem:
The new release of hunspell (already packaged in Fedora 16 alpha) provides enhanced hyphen handling, required for a new release of the Dutch OpenTaal spellchecking dictionary.

Version-Release number of selected component (if applicable):
1.2.15

Steps to Reproduce:
1. hunspell -v
2.
3.

Comment 1 Caolan McNamara 2011-09-09 14:45:18 UTC
Its in rawhide already. The hunspell-nl of F15 doesn't need it, right ? I'm not sure if a bump to 1.3 would require a rebuild of everything in F15 that links against it, i.e. new soname and/or abi changes. I'm generally reluctant to mess with the stable released fedoras.

Comment 2 Reinout van Schouwen 2011-09-10 22:35:01 UTC
(In reply to comment #1)
> The hunspell-nl of F15 doesn't need it, right? 

That's correct. However, as soon as the new OpenTaal dictionary 2.1.0 is out, an update to hunspell-nl and the firefox/libreoffice langpacks would be in order as well. 

> sure if a bump to 1.3 would require a rebuild of everything in F15 that links
> against it, i.e. new soname and/or abi changes. I'm generally reluctant to mess
> with the stable released fedoras.

I couldn't say if it would require a rebuild, but I do know the new version brings some significant improvements to the Dutch spellchecker.

Comment 3 Caolan McNamara 2011-09-11 14:13:28 UTC
hmm, ideally would be great to identify what commits brought in the required changes/improvements and selectively take them if possible.

http://hunspell.cvs.sourceforge.net/viewvc/hunspell/hunspell/src/hunspell/

Comment 4 Reinout van Schouwen 2011-09-13 13:10:03 UTC
According to the OpenTaal project leader, the changes that lead toward 1.3 were almost all driven by the requirements for Dutch, so I'm afraid that cherry-picking patches doesn't make sense.

Comment 5 Caolan McNamara 2011-09-16 11:35:10 UTC
Yeah, looking through it that seems to be the case alright. Hmm, pseudo- keep the same soname but upgrade to 1.3.2 sounds also a horror, there are subtle api changes too which may have an effect on non-rebuilt libs even then.

I'd rather not mess with the released stable release with a effectively base lib of so many applications.