Bug 737243

Summary: unfortunate handling of image after failing resize
Product: [Fedora] Fedora Reporter: Mads Kiilerich <mads>
Component: livecd-toolsAssignee: Brian Lane <bcl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: adam.stokes, bcl, bruno, dhuff, Jasper.Hartline, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: livecd-tools-16.6-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-23 04:04:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mads Kiilerich 2011-09-10 10:27:53 UTC
This is a fork of bug 737069 :

1: livecd-creator creates a sparse copy of the e2fs image before it starts resizing. It will probably not use a lot of disk space, even though it appears to have the same size as the original image, but it will take quite some time to generate it. Creating this debug image made a lot of sense back then when resize2fs frequently failed, but now there is longer any need for it.

2: If the resize of the real image fails then the real image will be removed immediately and the user will be referenced to the 'debug image'. That is very confusing if the resize fails because of lack of disk space. resize2fs gives no (clear) hint that lack of disk space is the problem, and there is plenty of disk space after livecd-creator terminates. I expect that the image is fully consistent and usable even after the failed resize, only less shallow than before - otherwise it would be a resize2fs bug. The partly resized image would probably in many cases be more relevant for debugging than the sparse debug image - and it would leave the system in the state where it failed so the user has a chance to analyse the problem and fix it.

So:

1: Please remove/disable the debug image functionality again (at least unless explicitly requested) and let us save some cpu cycles.

2: Instead, please keep the real image even after failure, tell the user where to find it, and leave it to the user to remove it.


livecd-tools-16.5-1.fc16.i686
e2fsprogs-1.41.14-2.fc15.i686

Comment 1 Brian Lane 2011-09-13 22:13:37 UTC
Pushed the change to master. It will be fixed in the next rawhide release.

Comment 2 Fedora Update System 2011-09-14 18:33:31 UTC
livecd-tools-16.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.6-1.fc16

Comment 3 Fedora Update System 2011-09-15 15:13:08 UTC
Package livecd-tools-16.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-16.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/livecd-tools-16.6-1.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-23 04:03:49 UTC
livecd-tools-16.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.