Bug 737489

Summary: VDSM - Storage: Deactivate succeeds but disconnect fails for ISO domain in use
Product: Red Hat Enterprise Linux 6 Reporter: Daniel Paikov <dpaikov>
Component: vdsmAssignee: Dan Kenigsberg <danken>
Status: CLOSED NOTABUG QA Contact: Daniel Paikov <dpaikov>
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: abaron, bazulay, hateya, iheim, ykaul
Target Milestone: rc   
Target Release: 6.1   
Hardware: Unspecified   
OS: Linux   
Whiteboard: Storage
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-12 12:42:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 703726    
Attachments:
Description Flags
vdsm.log none

Description Daniel Paikov 2011-09-12 09:46:21 UTC
Created attachment 522671 [details]
vdsm.log

The fix for backend bug #703726 exposed the following bug in VDSM:

* Start VM with connected ISO image.
* Deactivate ISO domain.
* Deactivate succeeds but disconnectStorageServer fails.

Thread-193432::INFO::2011-09-11
15:20:12,542::dispatcher::94::Storage.Dispatcher.Protect::(run) Run and
protect: disconnectStorageServer, args: (domType=1, spUUID=000000
00-0000-0000-0000-000000000000, conList=[{'connection':
'qanashead.qa.lab.tlv.redhat.com:/export/shared_iso_domain', 'iqn': '',
'portal': '', 'user': '', 'password': '**
****', 'id': '13cf9c55-2133-4e42-a3d4-cedb1e637c55', 'port': ''}])
Thread-193432::INFO::2011-09-11
15:20:13,052::dispatcher::100::Storage.Dispatcher.Protect::(run) Run and
protect: disconnectStorageServer, Return response: {'status': {'
message': 'OK', 'code': 0}, 'statuslist': [{'status': 452, 'id':
'13cf9c55-2133-4e42-a3d4-cedb1e637c55'}]}