Bug 737856

Summary: Crimilan C+ mouse wheel do not works
Product: [Fedora] Fedora Reporter: Pierre Blavy <pierreblavy>
Component: xorg-x11-drv-evdevAssignee: Peter Hutterer <peter.hutterer>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-16 01:13:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pierre Blavy 2011-09-13 09:34:14 UTC
Description of problem:
When scrolling the mouse well in one direction the windows cursor goes up and down

There do not seems to be a specific pattern (on scroll up may randomly result in one scroll up or one scroll down).

How reproducible:
Always

Steps to Reproduce:
1.Plug the mouse
2.Open any windows with a cursor
3.Scroll 

Actual results:
Scrolling fails
Bad mouse name in lsusb

Expected results:
Scrolling up must scroll up
Scrolling down must scroll down

Additional info:
Tested in konsole, firefox and kwrite under the latest (13 sept 2011) KDE desktop.

HARDWARE SPECIFIC BUG : scrolling works with my dell mouse, fails with my Criminal C+ one

lsusb identify my criminal C+ mouse as:
Bus 001 Device 004: ID 09da:000e A4 Tech Co., Ltd 
But it's a textorm mouse, not an A4

This bug has already happen in the past and was fixed but I cannot find the old bug report.

Comment 1 Josh Boyer 2011-10-20 15:31:12 UTC
That last bug was 539548 which was fixed by some kind of xorg update.  Let's route this to xorg-x11-drv-evdev for now.

As for the A4 Tech listing in the lsusb output, my guess is that it's just a Textorm rebranded A4 Tech mouse.  The other bug showed the same thing as well.  According to the USB ID, it's probably an A4Tech X-718.

Comment 2 Peter Hutterer 2011-11-11 03:36:17 UTC
Is this still an issue?

What's the evtest output when you scroll?

Comment 3 Peter Hutterer 2012-01-16 01:13:28 UTC
Closing due to missing data. Please reopen when the evtest output is available.

Comment 4 Pierre Blavy 2012-01-16 08:37:45 UTC
After investigation it's a pure hardware problem. Something is broken in the USB plug, therefore after unplug + replug it works most of the time. The bad luck is that working was correlated to non linux OS by chance.

Appologies for the false alert.