Bug 738425

Summary: Multiple users can be created with the same username
Product: [Retired] Katello Reporter: Jeff Weiss <jweiss>
Component: WebUIAssignee: Jason E. Rist <jrist>
Status: CLOSED WORKSFORME QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 1.0CC: dajohnso, gstoecke, mmccune
Target Milestone: ---Keywords: TestBlocker
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-14 21:47:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeff Weiss 2011-09-14 18:31:02 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.81-1.git.14.bd7aa7c.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. Create user "myuser1"
2. Create user "myuser1" again
3.
  
Actual results:
2 users created, with same name, both show up in left pane

Expected results:
2nd create fails with message like "User 'myuser1' already exists"

Additional info:

Comment 1 Jeff Weiss 2011-09-14 18:31:26 UTC
This is with the "database" warden.

Comment 2 Jeff Weiss 2011-09-14 21:47:58 UTC
Ohhhkay, I swear this was broken, can't reproduce it on the very next build.  Will reopen if I see again.