Bug 738670

Summary: Coredump every login: reading seahorse settings ?
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: GConf2Assignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mclasen, rstrode, sergio.pasra, walters
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-14 01:15:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom London 2011-09-15 14:00:28 UTC
Description of problem:
See this in ~/.xsession-errors:

GLib-GIO-ERROR **: Settings schema 'org.gnome.seahorse.recipients' does not contain a key named 'show-validity'
gnome-session[1476]: WARNING: Application 'gsettings-data-convert.desktop' killed by signal

GLib-GIO-ERROR **: Settings schema 'org.gnome.seahorse.recipients' does not contain a key named 'show-validity'
gnome-session[1476]: WARNING: Application 'gsettings-data-convert.desktop' killed by signal
gnome-session[1476]: WARNING: App 'gsettings-data-convert.desktop' respawning too quickly
gnome-session[1476]: WARNING: Error on restarting session managed app: Component 'gsettings-data-convert.desktop' crashing too quickly

See this from core dumps:

Core was generated by `gsettings-data-convert'.
Program terminated with signal 5, Trace/breakpoint trap.
#0  g_logv (log_domain=0x3c412ee221 "GLib-GIO", log_level=<optimized out>, 
    format=0x3c41306938 "Settings schema '%s' does not contain a key named '%s'", args1=0x7fffeade9a48) at gmessages.c:577
577		  g_private_set (g_log_depth, GUINT_TO_POINTER (depth));
Missing separate debuginfos, use: debuginfo-install libselinux-2.1.5-5.fc17.x86_64
(gdb) set pagination off
(gdb) bt full
#0  g_logv (log_domain=0x3c412ee221 "GLib-GIO", log_level=<optimized out>, format=0x3c41306938 "Settings schema '%s' does not contain a key named '%s'", args1=0x7fffeade9a48) at gmessages.c:577
        depth = 0
        domain = 0x0
        data = 0x0
        log_func = 0x3c3fa4c7e0 <g_log_default_handler>
        domain_fatal_mask = <optimized out>
        masquerade_fatal = <optimized out>
        test_level = <optimized out>
        was_fatal = 0
        was_recursion = 0
        i = <optimized out>
#1  0x0000003c3fa4d6c2 in g_log (log_domain=<optimized out>, log_level=<optimized out>, format=<optimized out>) at gmessages.c:591
        args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7fffeade9b20, reg_save_area = 0x7fffeade9a60}}
#2  0x0000003c412a2305 in g_settings_schema_get_value (schema=0xf4d940 [GSettingsSchema], key=0xf52490 "show-validity") at gsettingsschema.c:312
        iter = <optimized out>
        value = 0x0
#3  0x0000003c412a3996 in g_settings_get_key_info (info=0x7fffeade9ba0, settings=0xf4d8f0 [GSettings], key=0xf52490 "show-validity") at gsettings.c:932
        iter = <optimized out>
        data = <optimized out>
        code = <optimized out>
        __PRETTY_FUNCTION__ = "g_settings_get_key_info"
#4  0x0000003c412a5eab in g_settings_set_value (settings=0xf4d8f0 [GSettings], key=0xf52490 "show-validity", value=0xf41b30) at gsettings.c:1561
        info = {settings = 0x0, key = 0x0, schema = 0x0, is_flags = 0, is_enum = 0, strinfo = 0x0, strinfo_length = 0, unparsed = 0x0, lc_char = 0 '\000', type = 0x0, minimum = 0x0, maximum = 0x0, default_value = 0x0}
        __PRETTY_FUNCTION__ = "g_settings_set_value"
#5  0x0000003c412a60ed in g_settings_set (settings=0xf4d8f0 [GSettings], key=0xf52490 "show-validity", format=<optimized out>) at gsettings.c:1659
        value = <optimized out>
        ap = {{gp_offset = 32, fp_offset = 48, overflow_arg_area = 0x7fffeade9d20, reg_save_area = 0x7fffeade9c50}}
#6  0x0000000000402d25 in handle_file (filename=<optimized out>) at gsettings-data-convert.c:199
        schema_path = <optimized out>
        keyfile = 0xf41040
        client = 0xf35520 [GConfClient]
        value = 0xf530a0
        i = <optimized out>
        j = <optimized out>
        gconf_key = 0xf524f0 "/apps/seahorse/listing/show_validity"
        groups = 0xf42980
        keys = 0xf523d0
        builder = <optimized out>
        v = <optimized out>
        s = <optimized out>
        str = <optimized out>
        ii = <optimized out>
        list = <optimized out>
        l = <optimized out>
        s = 0xf4d8f0 [GSettings]
        error = 0x0
#7  0x0000000000402300 in handle_dir (converted=0xf352a0, stored_mtime=1315315561, dirname=0xf40020 "/usr/share/GConf/gsettings") at gsettings-data-convert.c:358
        statbuf = {st_dev = 64768, st_ino = 14552106, st_nlink = 2, st_mode = 16877, st_uid = 0, st_gid = 0, __pad0 = 0, st_rdev = 0, st_size = 4096, st_blksize = 4096, st_blocks = 8, st_atim = {tv_sec = 1316093162, tv_nsec = 504862598}, st_mtim = {tv_sec = 1315762877, tv_nsec = 209359380}, st_ctim = {tv_sec = 1315762877, tv_nsec = 209359380}, __unused = {0, 0, 0}}
        dir = 0xf40110
        dir_mtime = <optimized out>
        name = 0xf43233 "org.gnome.seahorse.recipients.convert"
        filename = 0xf42c60 "/usr/share/GConf/gsettings/org.gnome.seahorse.recipients.convert"
        error = 0x0
#8  main (argc=1, argv=0x7fffeadea098) at gsettings-data-convert.c:592
        convert_dir = 0xf40020 "/usr/share/GConf/gsettings"
        stored_mtime = 1315315561
        data_dirs = <optimized out>
        i = <optimized out>
        error = 0x0
        context = <optimized out>
        extra_file = 0x0
        entries = {{long_name = 0x4031d7 "verbose", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x6042a8, description = 0x4031df "show verbose messages", arg_description = 0x0}, {long_name = 0x4031f5 "dry-run", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x6042ac, description = 0x4031fd "do not perform any changes", arg_description = 0x0}, {long_name = 0x403218 "file", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_STRING, arg_data = 0x7fffeade9f68, description = 0x4033a0 "perform conversions from an extra file", arg_description = 0x0}, {long_name = 0x0, short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x0, description = 0x0, arg_description = 0x0}}
(gdb) 


Version-Release number of selected component (if applicable):
GConf2-3.1.90-1.fc16.x86_64

How reproducible:
Every login

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2011-09-15 14:04:12 UTC
Checking the file, 'show_validity' appears to be there....

[tbl@tlondon ~]$ ls -l /home/tbl/.gconf/apps/seahorse/listing/%gconf.xml 
-rw-------. 1 tbl tbl 430 Aug 19 06:54 /home/tbl/.gconf/apps/seahorse/listing/%gconf.xml
[tbl@tlondon ~]$ cat /home/tbl/.gconf/apps/seahorse/listing/%gconf.xml 
<?xml version="1.0"?>
<gconf>
	<entry name="sort_by" mtime="1313762001" type="string">
		<stringvalue>id</stringvalue>
	</entry>
	<entry name="show_expires" mtime="1313761980" type="bool" value="true"/>
	<entry name="show_trust" mtime="1313761980" type="bool" value="true"/>
	<entry name="show_type" mtime="1313761980" type="bool" value="true"/>
	<entry name="show_validity" mtime="1313761980" type="bool" value="true"/>
</gconf>
[tbl@tlondon ~]$

Comment 2 Tom London 2011-09-22 13:55:20 UTC
Still seeing this with GConf2-3.1.92-1.fc17.x86_64:

Core was generated by `gsettings-data-convert'.
Program terminated with signal 5, Trace/breakpoint trap.
#0  g_logv (log_domain=0x7f09d7b036e1 "GLib-GIO", log_level=<optimized out>, 
    format=0x7f09d7b1bdd8 "Settings schema '%s' does not contain a key named '%s'", args1=0x7fff4b3401e8) at gmessages.c:577
577		  g_private_set (g_log_depth, GUINT_TO_POINTER (depth));
(gdb) set pagination off
(gdb) bt full
#0  g_logv (log_domain=0x7f09d7b036e1 "GLib-GIO", log_level=<optimized out>, format=0x7f09d7b1bdd8 "Settings schema '%s' does not contain a key named '%s'", args1=0x7fff4b3401e8) at gmessages.c:577
        depth = 0
        domain = 0x0
        data = 0x0
        log_func = 0x7f09d74ef920 <g_log_default_handler>
        domain_fatal_mask = <optimized out>
        masquerade_fatal = <optimized out>
        test_level = <optimized out>
        was_fatal = 0
        was_recursion = 0
        i = <optimized out>
#1  0x00007f09d74f0802 in g_log (log_domain=<optimized out>, log_level=<optimized out>, format=<optimized out>) at gmessages.c:591
        args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7fff4b3402c0, reg_save_area = 0x7fff4b340200}}
#2  0x00007f09d7ab7405 in g_settings_schema_get_value (schema=0x1841940 [GSettingsSchema], key=0x1845fd0 "show-validity") at gsettingsschema.c:312
        iter = <optimized out>
        value = 0x0
#3  0x00007f09d7ab8a96 in g_settings_get_key_info (info=0x7fff4b340340, settings=0x18418f0 [GSettings], key=0x1845fd0 "show-validity") at gsettings.c:932
        iter = <optimized out>
        data = <optimized out>
        code = <optimized out>
        __PRETTY_FUNCTION__ = "g_settings_get_key_info"
#4  0x00007f09d7abafab in g_settings_set_value (settings=0x18418f0 [GSettings], key=0x1845fd0 "show-validity", value=0x1836330) at gsettings.c:1561
        info = {settings = 0x0, key = 0x0, schema = 0x0, is_flags = 0, is_enum = 0, strinfo = 0x0, strinfo_length = 0, unparsed = 0x0, lc_char = 0 '\000', type = 0x0, minimum = 0x0, maximum = 0x0, default_value = 0x0}
        __PRETTY_FUNCTION__ = "g_settings_set_value"
#5  0x00007f09d7abb1ed in g_settings_set (settings=0x18418f0 [GSettings], key=0x1845fd0 "show-validity", format=<optimized out>) at gsettings.c:1659
        value = <optimized out>
        ap = {{gp_offset = 32, fp_offset = 48, overflow_arg_area = 0x7fff4b3404c0, reg_save_area = 0x7fff4b3403f0}}
#6  0x0000000000402d25 in handle_file (filename=<optimized out>) at gsettings-data-convert.c:199
        schema_path = <optimized out>
        keyfile = 0x1835440
        client = 0x1829520 [GConfClient]
        value = 0x1846880
        i = <optimized out>
        j = <optimized out>
        gconf_key = 0x18429e0 "/apps/seahorse/listing/show_validity"
        groups = 0x1835370
        keys = 0x1845ac0
        builder = <optimized out>
        v = <optimized out>
        s = <optimized out>
        str = <optimized out>
        ii = <optimized out>
        list = <optimized out>
        l = <optimized out>
        s = 0x18418f0 [GSettings]
        error = 0x0
#7  0x0000000000402300 in handle_dir (converted=0x18292a0, stored_mtime=1315315561, dirname=0x1833df0 "/usr/share/GConf/gsettings") at gsettings-data-convert.c:358
        statbuf = {st_dev = 64768, st_ino = 14552106, st_nlink = 2, st_mode = 16877, st_uid = 0, st_gid = 0, __pad0 = 0, st_rdev = 0, st_size = 4096, st_blksize = 4096, st_blocks = 8, st_atim = {tv_sec = 1316699101, tv_nsec = 121933591}, st_mtim = {tv_sec = 1316611441, tv_nsec = 927282522}, st_ctim = {tv_sec = 1316611441, tv_nsec = 927282522}, __unused = {0, 0, 0}}
        dir = 0x1833e20
        dir_mtime = <optimized out>
        name = 0x18372a3 "org.gnome.seahorse.recipients.convert"
        filename = 0x1833f30 "/usr/share/GConf/gsettings/org.gnome.seahorse.recipients.convert"
        error = 0x0
#8  main (argc=1, argv=0x7fff4b340838) at gsettings-data-convert.c:592
        convert_dir = 0x1833df0 "/usr/share/GConf/gsettings"
        stored_mtime = 1315315561
        data_dirs = <optimized out>
        i = <optimized out>
        error = 0x0
        context = <optimized out>
        extra_file = 0x0
        entries = {{long_name = 0x4031d7 "verbose", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x6042a8, description = 0x4031df "show verbose messages", arg_description = 0x0}, {long_name = 0x4031f5 "dry-run", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x6042ac, description = 0x4031fd "do not perform any changes", arg_description = 0x0}, {long_name = 0x403218 "file", short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_STRING, arg_data = 0x7fff4b340708, description = 0x4033a0 "perform conversions from an extra file", arg_description = 0x0}, {long_name = 0x0, short_name = 0 '\000', flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x0, description = 0x0, arg_description = 0x0}}
(gdb)

Comment 3 Tom London 2011-09-22 14:06:46 UTC
A bit more:

[root@tlondon ~]# cat /usr/share/GConf/gsettings/org.gnome.seahorse.recipients.convert
[org.gnome.seahorse.recipients]
show-validity = /apps/seahorse/listing/show_validity
show-expiry = /apps/seahorse/listing/show_expires
show-trust = /apps/seahorse/listing/show_trust
show-type = /apps/seahorse/listing/show_type
sort-by = /apps/seahorse/listing/sort_by[root@tlondon ~]#

Comment 4 Sergio Pascual 2011-11-29 23:23:39 UTC
I have fixed this by uninstalling and installing seahorse. Now it works for me (no more segfaults)

Comment 5 Sergio Pascual 2011-11-30 06:40:59 UTC
After rebooting, I have seen the segfaults again. The only workaround is uninstalling seahorse completely

Comment 6 Matthias Clasen 2012-02-14 01:15:05 UTC
Looks like this has been fixed in seahorse by now; there is no file named org.gnome.seahorse.recipients.convert anymore, and the existing conversion files work fine here.