Bug 739834

Summary: InitialFact path has changed
Product: [JBoss] JBoss Enterprise BRMS Platform 5 Reporter: Tomas Schlosser <tschloss>
Component: BRE (Expert, Fusion), JONAssignee: Edson Tirelli <etirelli>
Status: CLOSED NOTABUG QA Contact: Tomas Schlosser <tschloss>
Severity: low Docs Contact:
Priority: unspecified    
Version: BRMS 5.2.0.GACC: atangrin, brms-jira, lpetrovi, mproctor
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-20 07:25:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Schlosser 2011-09-20 07:46:07 UTC
Description of problem:
InitialFact used to be represented (when inspecting through jConsole) by class 'org.drools.InitialFact' but now it changed to 'org.drools.reteoo.InitialFactImpl'.

Version-Release number of selected component (if applicable):
BRMS 5.2.0.ER4

How reproducible:
every time

Steps to Reproduce:
1. create simple DRL with empty LHS
2. create MBeans enabled knowledge base
3. inspect the process using jConsole
  
Actual results:
org.drools.reteoo.InitialFactImpl

Expected results:
org.drools.InitialFact

Additional info:

Comment 2 Edson Tirelli 2012-01-19 23:44:26 UTC
The initial fact is a very deep implementation detail of the underlying algorithm and is not part of the interface contract with users. Users should not be doing anything with it, nor relying on its name/class. Inside the engine, we completely hide it from the user (for instance, users can't access it on the RHS of rules), but obviously, the JMX console gives a JVM view and there is no way to hide it in there.

Is this package name change affecting something I am not aware of?

Comment 3 Tomas Schlosser 2012-01-20 07:16:12 UTC
It doesn't break anything as far as I know. If it is all right with you, just close it with NOTABUG.
The bug was reported because it changed the behaviour between BRMS 5.1.0 and 5.2.0.