Bug 739860

Summary: python-urlgrabber-3.9.1-8.el6 is missing support for basic auth
Product: Red Hat Enterprise Linux 6 Reporter: Tuomo Soini <tis>
Component: python-urlgrabberAssignee: Valentina Mukhamedzhanova <vmukhame>
Status: CLOSED WONTFIX QA Contact: BaseOS QE - Apps <qe-baseos-apps>
Severity: low Docs Contact:
Priority: unspecified    
Version: 6.1CC: aupadhye, c.handel, jzeleny, pahan
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-09-18 13:54:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 947775, 1002711, 1070830, 1159820    

Description Tuomo Soini 2011-09-20 08:44:03 UTC
yum supports basic auth by username and password options.

python urlgrabber is missing commit c2a06002be467b8395e420fea9a629d6dc14ddbc for basic auth support. So while yum gives auth info to urlgrabber urlgrabber doesn't currently know what to do with it.

Comment 2 RHEL Program Management 2011-09-20 09:08:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 James Antill 2011-09-21 15:44:39 UTC
 Simple backport of an upstream fix ... it "works" now but you have to use https://username:password@host/path ... and it shows the auth. info. on errors (or whenever yum shows the url), which can be pretty annoying.

Comment 6 Suzanne Logcher 2012-02-14 23:16:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 RHEL Program Management 2013-10-14 00:57:26 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 9 Chris Williams 2015-09-18 13:54:40 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.