Bug 740017

Summary: DisallowTCP=false appears broken in Fedora 15.
Product: [Fedora] Fedora Reporter: Ben Greear <greearb>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-20 18:01:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ben Greear 2011-09-20 17:40:51 UTC
Description of problem:

I want to be able to telnet to a remote system, set: export DISPLAY=foo:0.0,
and be able to run xterm and have it pop up on the local desktop.

Yes, I know ssh is better in many cases.

On Fedora 14 and earlier, one could add this to /etc/gdm/custom.com:

[security]
DisallowTCP=false

This appears to no longer work in Fedora 15.

Version-Release number of selected component (if applicable):


How reproducible:

Always.


Steps to Reproduce:
1. xhost +
2. telnet [remote-system]
3. export DISPLAY=[ip-of-local-system]:0.0
4  xterm&
5. xterm should display on local system.
  
Actual results:

xterm will not launch due to DISPLAY issues.


Expected results:

xterm should pop up on local system.

Additional info:

Appears to be regression..this worked on Fedora 13 and earlier, and I believe it worked on Fedora 14 as well.

Comment 1 Ben Greear 2011-09-20 18:01:57 UTC
Err, this appears to be some issue related to firewalls.  I used to use ntsysv
to disable the firewall, but while that sort of appears to work, it doesn't actually keep the iptables rules from being loaded.  So, that is the root cause of the X display not working.  With manual stop of iptables, it the DisallowTCP option works as desired.