Bug 740124

Summary: Text string search on message list view falsely returns "no data to display"
Product: [Retired] Zanata Reporter: Ding-Yi Chen <dchen>
Component: Component-UIAssignee: Alex Eng <aeng>
Status: CLOSED CANTFIX QA Contact: Ding-Yi Chen <dchen>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 1.4-RCCC: zanata-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-21 04:33:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ding-Yi Chen 2011-09-21 02:11:02 UTC
Description of problem:
Even search a text string within messages,
it still returns "There is no data to display"

But search numbers works.

Version-Release number of selected component (if applicable):
Zanata version 1.4-alpha-2-SNAPSHOT (20110920-1458)

How reproducible:
Always

Steps to Reproduce:
1. Visit Fedora Readme and one of version.
2. Visit Document Revision_History
3. "Fedora" is on message 2,3,4; click on search field and type "Fedora"
  
Actual results:
message list shows 
"There is no data to display"

Expected results:
Message 2,3,4 are returned, with "Fedora" highlighted.


Additional info:
 Zanata version 1.3 (20110509-2113) does not have this problem

Comment 1 Alex Eng 2011-09-21 02:41:29 UTC
Bug fixed along with https://bugzilla.redhat.com/show_bug.cgi?id=739427 fixes.

Comment 2 Ding-Yi Chen 2011-09-21 04:33:44 UTC
After some investigation, this problem happened in H2 backend ones but not MySQL ones, thus this might be actually H2 bug.