Bug 740284

Summary: nscd.service definition improvement
Product: [Fedora] Fedora Reporter: Marcus Moeller <marcus.moeller>
Component: glibcAssignee: Andreas Schwab <schwab>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: fweimer, jakub, johannbg, schwab
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glibc-2.14.90-10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-02 18:13:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marcus Moeller 2011-09-21 14:27:08 UTC
Could the nscd unit file please be improved as follows:

[Unit]
Description=Name Switch Cache Daemon
After=syslog.target network.target

[Service]
Type=forking
PIDFile=/run/nscd/nscd.pid
EnvironmentFile=-/etc/sysconfig/nscd
ExecStart=/usr/sbin/nscd $NSCD_OPTIONS
ExecReload=/usr/sbin/nscd -i passwd
ExecReload=/usr/sbin/nscd -i group
ExecReload=/usr/sbin/nscd -i hosts
ExecReload=/usr/sbin/nscd -i services
ExecStop=/usr/sbin/nscd -K

[Install]
WantedBy=multi-user.target

...

This would also require a modification of /etc/tmpfiles.d/nscd.conf:

d /run/nscd 0755 root root -

It would also be great to have these in F15 as the classic nscd init cause some weird problems with NetworkManager:

https://bugzilla.redhat.com/show_bug.cgi?id=739902

Comment 1 J├│hann B. Gu├░mundsson 2011-09-21 14:39:39 UTC
Adding me to the bug since I wrote that unit file along with the tmpfile

Comment 2 Fedora Update System 2011-09-28 14:01:55 UTC
glibc-2.14.90-10 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-12845

Comment 3 Fedora Update System 2011-09-28 18:52:43 UTC
Package glibc-2.14.90-10:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.14.90-10'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.14.90-10
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-10-02 18:13:04 UTC
glibc-2.14.90-10 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.