Bug 740325

Summary: R200 misrenders some mesa demos
Product: Red Hat Enterprise Linux 6 Reporter: Vitezslav Humpa <vhumpa>
Component: xorg-x11-drv-atiAssignee: Jérôme Glisse <jglisse>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.8CC: xgl-maint
Target Milestone: rcKeywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 679588 Environment:
Last Closed: 2017-12-06 07:42:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 679588    
Bug Blocks: 842499    
Attachments:
Description Flags
spectex HW rendering
none
spectex SW rendering none

Description Vitezslav Humpa 2011-09-21 12:19:39 EDT
+++ This bug was initially created as a clone of Bug #679588 +++

Description of problem:
R200 misrenders many of the mesa demos.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.14.2-6.el6
ATI Technologies Inc RV200 [Radeon 8500]

How reproducible:
Always

Steps to Reproduce:
1. Run e.g. reflect or spectex (in /usr/lib/mesa)
2. See the output as compared to when run with LIBGL_ALWAYS_SOFTWARE=1

Actual results:
Reflect doesn't seem to be lit
Misrendered ball in spectex
And more with the other demos.

Expected results:
Images are fairly close to identical to the software rendering.

Additional info:
Nothing particular in Xorg log or messages.

See the Fedora bug for example screenshots of reflex rendering. Spectex example will be attached.
Comment 1 Vitezslav Humpa 2011-09-21 12:22:38 EDT
Created attachment 524241 [details]
spectex HW rendering
Comment 2 Vitezslav Humpa 2011-09-21 12:32:17 EDT
Created attachment 524243 [details]
spectex SW rendering
Comment 4 RHEL Product and Program Management 2011-10-07 12:13:56 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 07:42:25 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/