Bug 740378

Summary: F16: Can't use keyboard when installing F16-Alpha under Xen (regression) as guest
Product: [Fedora] Fedora Reporter: Konrad Rzeszutek Wilk <ketuzsezr>
Component: anacondaAssignee: Martin Gracik <mgracik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: anaconda-maint-list, dmach, jonathan, lersek, m.a.young, pasik, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lorax-16.4.6-1.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 741950 (view as bug list) Environment:
Last Closed: 2011-09-26 08:36:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 741950    
Attachments:
Description Flags
Screenshot of vncviewer localhost:0 - none of the keys pressed are sent to anaconda.
none
Text output from 'xm console' with debug options. none

Description Konrad Rzeszutek Wilk 2011-09-21 15:49:29 EDT
Created attachment 524269 [details]
Screenshot of vncviewer localhost:0 - none of the keys pressed are sent to anaconda.

Description of problem:

When I try to install F16 as DomU under Xen the installer (text)
does not recognize any of the keys I am pressing. If I use the VNC F8 to send Ctrl-Alt-Del nothing happens.

Version-Release number of selected component (if applicable):

Whatever is in the F16-Alpha
How reproducible:


Steps to Reproduce:
1. cat > F16.xm
kernel = "/tmp/vmlinuz"
ramdisk="/tmp/initrd.img"
#extra="askmethod"
memory = 1024
name = "Fedora"
vcpus=2
vif = [ 'mac=00:0F:4B:00:00:63,bridge=switch' ]
disk = [ 'phy:/dev/vg_guest/FC16-64,xvda,w' ]
vfb = [ 'vnc=1, vnclisten=0.0.0.0,vncunused=1']


2. xm create -c F16.xm
3. vncviewer localhost:0

Actual results:

No keyboard response.
Expected results:

Keyboard response
Additional info:

I did manage to install FC16 using workarounds. Mainly on the 'extra'
line I added 'console=hvc0 test serial vnc' and I was able to hit keys
in the text console (so the one provided by xm console), but still not in the VNC provided by the framebuffer. And the selection of the packages was done via vncviewer <guest-ip>:0.

After the install was finished I poked around in the initrd and noticed that the xen-kbdfront was missing.

But I couldn't figure out a way to insert the xen-kbfront during the install - either via unpacking the xz initrd img (tried the alpha version), nor disk images. Perhaps there is a link explaining how to create one?
Comment 1 Konrad Rzeszutek Wilk 2011-09-21 15:54:13 EDT
Created attachment 524270 [details]
Text output from 'xm console' with debug options.

Screen output based off:
#cat F16.xm
kernel = "/tmp/vmlinuz"
ramdisk="/tmp/initrd.img"
extra="debug initcall_debug loglevel=10"
memory = 1024
name = "Fedora"
vcpus=2
vif = [ 'mac=00:0F:4B:00:00:63,bridge=switch' ]
disk = [ 'phy:/dev/vg_guest/FC16-64,xvda,w' ]
vfb = [ 'vnc=1, vnclisten=0.0.0.0,vncunused=1']
#xm create -c F16
Comment 2 Konrad Rzeszutek Wilk 2011-09-21 16:03:21 EDT
There is a workaround for this which is to do:

extra="vnc lang=en_US.UTF-8 keymap=us"

Anyhow, I am more than happy to test say, an kernel and initrd.img that have an xen-kbdfront injected in it...

Does F16 use the old RHEL5 method of manually loading some specific modules? Or does it nowadays use the udev mechanism?
Comment 3 Konrad Rzeszutek Wilk 2011-09-27 14:15:24 EDT
I am having a hard time actually finding this version (17.0) in the rawhide or F16 initrd.img. 

This URL http://fedora.mirror.ac.za/linux/development/rawhide/x86_64/os/Packages/ shows that lorax-16.4.2 is going in rawhide/f16.
Sooo when will 17.0 be in?

It is rather impossible to test this without using an initrd image, so I can't very well do 'yum update' during an install when I can't use the keyboard.
Comment 4 Fedora Update System 2011-10-03 10:03:51 EDT
lorax-16.4.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.5-1.fc16
Comment 5 Laszlo Ersek 2011-10-03 12:42:40 EDT
*** Bug 740657 has been marked as a duplicate of this bug. ***
Comment 6 Laszlo Ersek 2011-10-03 12:53:14 EDT
I figure the "test" extra arg in the comments above is "text" in reality.
Comment 7 Fedora Update System 2011-10-11 13:54:00 EDT
lorax-16.4.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lorax-16.4.6-1.fc16
Comment 8 Fedora Update System 2011-10-13 00:32:45 EDT
lorax-16.4.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.