Bug 74044

Summary: Does not work when installed with an umask of 077 and messes filesystem
Product: [Retired] Red Hat Linux Reporter: Enrico Scholz <rh-bugzilla>
Component: anaconda-imagesAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.tu-chemnitz.de/~ensc/dircheck/null/packages.html#anaconda-images-7.3.94-1
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-25 13:33:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Enrico Scholz 2002-09-13 20:34:56 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /usr/share/anaconda /usr/share/anaconda/pixmaps
| file /usr/share/anaconda is not owned by any package
| anaconda-images-7.3.94-1

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

anaconda-images-7.3.94-1


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that anaconda-images is uninstalled completely
   (rm -rf /usr/share/anaconda)
3. rpm -U anaconda-images-7.3.94-1.noarch.rpm
4. ls -l /usr/share/anaconda
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e anaconda-images-7.3.94-1


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 21:41 /usr/share/anaconda
* files can not be found/read at 5 and
* /usr/share/anaconda still exists after 6.

Comment 1 Jeremy Katz 2002-10-01 22:02:51 UTC
Fixed in cvs

Comment 2 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated

Comment 3 Enrico Scholz 2003-02-25 13:33:57 UTC
Fix verified. Thanks.