Bug 740822 (CVE-2011-3372)

Summary: CVE-2011-3372 cyrus-imapd: nntpd authentication bypass
Product: [Other] Security Response Reporter: Jan Lieskovsky <jlieskov>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: mhlavink, security-response-team, vdanen
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=moderate,public=20111005,reported=20110923,source=vendor-sec,cvss2=5.8/AV:N/AC:M/Au:N/C:P/I:P/A:N,rhel-4/cyrus-imapd=affected,rhel-5/cyrus-imapd=affected,rhel-6/cyrus-imapd=affected,fedora-all/cyrus-imapd=affected
Fixed In Version: cyrus-imapd 2.4.12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-01 12:08:40 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 741698, 741699, 741700, 741701, 741702, 833885, 844263    
Bug Blocks: 740836    
Attachments:
Description Flags
Proposed Cyrus upstream patch to correct this issue against master branch
none
Proposed Cyrus upstream patch to correct this issue against v2.4 branch
none
Proposed Cyrus upstream patch to correct this issue against v2.3 branch none

Description Jan Lieskovsky 2011-09-23 09:28:45 EDT
It was found that the Cyrus NNTP daemon (nntpd) did not properly verify that the user has successfully authenticated when checking if client requested NNTP commands can be performed. A remote NNTP client could use this flaw to bypass the authentication mechanism and obtain access to the information that should require authentication (list of newsgroups, newsgroup messages) or post new messages.

Acknowledgement:

Red Hat would like to thank Cyrus IMAP project for reporting this issue. Upstream acknowledges Stefan Cornelius of Secunia Research as the original reporter.
Comment 1 Jan Lieskovsky 2011-09-23 09:30:30 EDT
This issue affects the versions of the cyrus-imapd package, as shipped with
Red Hat Enterprise Linux 4, 5, and 6.

--

This issue affects the versions of the cyrus-imapd package, as shipped with Fedora release of 14 and 15.
Comment 3 Jan Lieskovsky 2011-09-23 09:33:31 EDT
Created attachment 524614 [details]
Proposed Cyrus upstream patch to correct this issue against master branch
Comment 4 Jan Lieskovsky 2011-09-23 09:34:32 EDT
Created attachment 524615 [details]
Proposed Cyrus upstream patch to correct this issue against v2.4 branch
Comment 5 Jan Lieskovsky 2011-09-23 09:35:07 EDT
Created attachment 524616 [details]
Proposed Cyrus upstream patch to correct this issue against v2.3 branch
Comment 8 Jan Lieskovsky 2011-09-23 10:16:53 EDT
The CVE identifier of CVE-2011-3372 has been assigned to this issue.
Comment 11 Vincent Danen 2011-10-05 10:55:28 EDT
This issue is now public:

http://cyrusimap.org/mediawiki/index.php/Latest_Updates
http://secunia.com/advisories/46093/
Comment 13 errata-xmlrpc 2011-12-01 11:46:12 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 4
  Red Hat Enterprise Linux 5
  Red Hat Enterprise Linux 6

Via RHSA-2011:1508 https://rhn.redhat.com/errata/RHSA-2011-1508.html