This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 741087

Summary: [abrt] kernel: WARNING: at drivers/gpu/drm/i915/i915_drv.c:387 __gen6_gt_wait_for_fifo+0x73/0x82 [i915]()
Product: [Fedora] Fedora Reporter: Mikko Tiihonen <mikko.tiihonen>
Component: xorg-x11-drv-intelAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: ajax, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:c3f804f9e5c1fc5fc7407db3c7a00d0325d260cd
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-03 17:09:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mikko Tiihonen 2011-09-25 04:06:57 EDT
abrt version: 2.0.5.980
abrt_version:   2.0.4.981
cmdline:        ro root=UUID=10033589-14c8-48f0-8d13-e2b4bf44fce6 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fi selinux=0 pcie_aspm=force i915.i915_enable_rc6=1 cgroup_disable=memory dma_debug_entries=65536
kernel:         undefined
reason:         WARNING: at drivers/gpu/drm/i915/i915_drv.c:387 __gen6_gt_wait_for_fifo+0x73/0x82 [i915]()
time:           Sun Sep 25 10:55:30 2011

backtrace:
:WARNING: at drivers/gpu/drm/i915/i915_drv.c:387 __gen6_gt_wait_for_fifo+0x73/0x82 [i915]()
:Hardware name: 42844DG
:Modules linked in: nls_utf8 udf tcp_lp ppdev parport_pc lp parport fuse lockd ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM iptable_mangle tun bridge stp llc rfcomm bnep coretemp btusb bluetooth binfmt_misc snd_hda_codec_conexant cdc_ncm usbnet mii cdc_wdm cdc_acm uvcvideo videodev media v4l2_compat_ioctl32 arc4 virtio_net kvm_intel kvm snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm uinput microcode joydev iTCO_wdt iTCO_vendor_support i2c_i801 snd_timer snd_page_alloc iwlagn mac80211 e1000e cfg80211 thinkpad_acpi rfkill snd soundcore sunrpc btrfs zlib_deflate libcrc32c firewire_ohci sdhci_pci firewire_core sdhci crc_itu_t mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1205, comm: Xorg Tainted: G        W   3.1.0-0.rc6.git0.3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057b32>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81057b64>] warn_slowpath_null+0x1a/0x1c
: [<ffffffffa0067685>] __gen6_gt_wait_for_fifo+0x73/0x82 [i915]
: [<ffffffffa00986d8>] i915_write32+0x47/0x57 [i915]
: [<ffffffffa0098c37>] gen6_ring_get_irq+0x61/0x7b [i915]
: [<ffffffffa0098c69>] blt_ring_get_irq+0x18/0x1a [i915]
: [<ffffffffa0075f25>] i915_wait_request+0x180/0x429 [i915]
: [<ffffffffa0076262>] ? i915_gem_flush_ring+0x61/0x147 [i915]
: [<ffffffff81117135>] ? virt_to_head_page+0xe/0x31
: [<ffffffffa00761ff>] i915_gem_object_wait_rendering+0x31/0x33 [i915]
: [<ffffffffa007b0d7>] i915_gem_do_execbuffer+0xc02/0x10d6 [i915]
: [<ffffffffa007b8ad>] i915_gem_execbuffer2+0xe5/0x148 [i915]
: [<ffffffff81137b16>] ? set_fd_set+0x3e/0x48
: [<ffffffffa001d784>] drm_ioctl+0x29e/0x37b [drm]
: [<ffffffffa007b7c8>] ? i915_gem_execbuffer+0x21d/0x21d [i915]
: [<ffffffff814b4205>] ? _cond_resched+0xe/0x22
: [<ffffffff8136a2f7>] ? input_event_to_user+0x74/0x81
: [<ffffffff8104402b>] ? should_resched+0xe/0x2d
: [<ffffffff814b4205>] ? _cond_resched+0xe/0x22
: [<ffffffff8113748f>] do_vfs_ioctl+0x452/0x493
: [<ffffffff8100f807>] ? sys_rt_sigreturn+0x1be/0x1eb
: [<ffffffff81137526>] sys_ioctl+0x56/0x7c
: [<ffffffff814bbfc2>] system_call_fastpath+0x16/0x1b

comment:
:Very basic gnome3 usage, mainly using gnome-terminal. Had resumed laptop from suspend an hour earlier.
:I have enable_rc6=1 in kernel options. GPU is sandy bridge i7-2630QM.

event_log:
:2011-09-25-11:06:50> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-09-25-11:06:50  Kernel oops has not been sent due to Couldn't resolve host name
:2011-09-25-11:06:50* (exited with 1)
Comment 1 Adam Jackson 2012-05-03 17:09:37 EDT

*** This bug has been marked as a duplicate of bug 772364 ***