Bug 741120

Summary: Grub2 is unable to boot Fedora 16 on Lenovo Thinkpad X220 Tablet
Product: [Fedora] Fedora Reporter: Leonid Kanter <leon>
Component: grub2Assignee: Peter Jones <pjones>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 16CC: anders_juel, awilliam, dcharlespyle, dennis, kchamart, marcus.husar, myllynen, pjones, the.ridikulus.rat, thibault.north, tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-24 15:16:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Leonid Kanter 2011-09-25 16:33:26 UTC
Description of problem:

Installed Fedora 16 from nightly build installation dvd, with "use entire disk" option. Laptop's bios doesn't recognize recognize fedora disk drive as a bootable disk. It tries in sequence to boot from hdd, network and then show boot menu. When I removed this drive and inserted into other laptop (Dell D620) - it booted OK.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Install F16 on X220 Tablet, install grub to /dev/sda (MBR)
2. Reboot
Actual results:

Laptop should boot to Fedora 16

Expected results:

It's unable to boot.

Comment 1 Thibault North 2011-10-03 19:20:15 UTC
Confirmed on F16 beta RC-4 for a X220.

Comment 2 D. Charles Pyle 2011-10-06 09:39:53 UTC
Confirmed also for F16 beta on a Dell Inspiron 560. I am left with a prompt that does nothing as follows:


I cannot type anything or run any commands (rescue or otherwise). This was with a fresh install of Fedora 16 Beta. I also tried to use yum to reinstall Grub2 and to remove it and replace it with grub to no avail. I was left with an unbootable system. Installation also warned about dependency problems between grub and grub2 during installation.

Initially, I tried to update my working Fedora 15 system running KDE 4.7.1 but this update to Fedora 16-Beta screwed up my system so badly that I couldn't even uninstall KDE, could not downgrade it, could not keep Gnome 3 running stably, and had literally thousands of dependency problems. After spending over 24 hours fixing over 3,000 dependency problems on the upgraded system, using several tools such as rpm, yum, rpmreaper, etc., no more could be fixed and I ended up finally giving up and doing the fresh installation of 16 beta. That is when I got the abovemost problem I mentioned.

When I had intially run the upgrade, I could not boot the system at all because the option to leave the original boot configuration intact failed to write the new kernel information to /boot/grub/grub.conf. I had to enter the information manually in a recovery shell just to get the system to boot.

Good thing I knew the risks of installing Beta software. :-)

Comment 3 Marcus Husar 2011-10-13 11:06:52 UTC
I can also confirm this problem for F16 beta on a Lenovo S205 (bios mode with msdos partitiontable, because the EFI is too buggy to use).

I am not able to boot from my internal harddisk, but can help out with a GRUB2 installed in the MBR of my usb flash drive.

The only thing I can see from GRUB2 is „GRUB Loading.“ (yes, only one dot). After two or three seconds the system reboots.

How can I debug this and help to fix these probems? I would be delighted to have no boot problems.

Many thanks

Comment 4 Brian Lane 2011-10-18 13:21:51 UTC
Try the update image from comment 19 in bug 735733

Comment 5 Marko Myllynen 2011-10-18 14:02:18 UTC
(In reply to comment #4)
> Try the update image from comment 19 in bug 735733

I can confirm that with

  updates=http://dlehman.fedorapeople.org/updates-735733.0.img nogpt

Fedora 16 Beta now boots and works on Lenovo Thinkpad X220.


Comment 6 Adam Williamson 2011-10-24 15:16:45 UTC

Fedora Bugzappers volunteer triage team

*** This bug has been marked as a duplicate of bug 735733 ***