Bug 741246

Summary: SELinux is preventing /usr/bin/passwd from 'write' accesses on the file /root/output.txt.
Product: [Fedora] Fedora Reporter: Vít Ondruch <vondruch>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:0f844484644be83531bf189012e11e05e186644f14bd28b67ac58395e08fd0f0
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-26 11:30:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Vít Ondruch 2011-09-26 11:29:16 UTC
abrt version: 2.0.5.980
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
reason:         SELinux is preventing /usr/bin/passwd from 'write' accesses on the file /root/output.txt.
time:           Mon Sep 26 13:28:41 2011

description:
:SELinux is preventing /usr/bin/passwd from 'write' accesses on the file /root/output.txt.
:
:*****  Plugin catchall (50.5 confidence) suggests  ***************************
:
:If you believe that passwd should be allowed write access on the output.txt file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep passwd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin leaks (50.5 confidence) suggests  ******************************
:
:If you want to ignore passwd trying to write access the output.txt file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/passwd /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                /root/output.txt [ file ]
:Source                        passwd
:Source Path                   /usr/bin/passwd
:Port                          <Neznámé>
:Host                          (removed)
:Source RPM Packages           passwd-0.78-3.fc15
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-32.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.1.0-0.rc6.git0.3.fc16.x86_64 #1 SMP Fri Sep 16
:                              12:26:22 UTC 2011 x86_64 x86_64
:Alert Count                   3
:First Seen                    Po 26. září 2011, 13:25:26 CEST
:Last Seen                     Po 26. září 2011, 13:27:29 CEST
:Local ID                      84b21105-852f-4900-9086-ba32e2d9726c
:
:Raw Audit Messages
:type=AVC msg=audit(1317036449.390:10): avc:  denied  { write } for  pid=5639 comm="passwd" path="/root/output.txt" dev=dm-0 ino=9362320 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1317036449.390:10): avc:  denied  { write } for  pid=5639 comm="passwd" path="/root/output.txt" dev=dm-0 ino=9362320 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1317036449.390:10): arch=x86_64 syscall=execve success=yes exit=0 a0=1bba790 a1=1bab860 a2=1bac5b0 a3=7fff476f2be0 items=0 ppid=5515 pid=5639 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=2 comm=passwd exe=/usr/bin/passwd subj=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: passwd,passwd_t,admin_home_t,file,write
:
:audit2allow
:
:#============= passwd_t ==============
:allow passwd_t admin_home_t:file write;
:
:audit2allow -R
:
:#============= passwd_t ==============
:allow passwd_t admin_home_t:file write;
:

Comment 1 Vít Ondruch 2011-09-26 11:30:10 UTC
ABRT testing, please disregard