Bug 741430

Summary: Add -F option to restorecon in /usr/share/dracut/modules.d/99base/selinux-loadpolicy.sh
Product: Red Hat Enterprise Linux 6 Reporter: Miroslav Grepl <mgrepl>
Component: dracutAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact: Release Test Team <release-test-team>
Severity: high Docs Contact:
Priority: urgent    
Version: 6.1CC: atodorov, borgan, dominick.grift, dwalsh, ebenes, evan, jkoten, julroy67, mgrepl, mmalik, mvadkert, omoris, pknirsch, rhbugzilla
Target Milestone: rcKeywords: TestBlocker
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 739618 Environment:
Last Closed: 2011-12-06 11:48:39 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 730449, 739618    
Bug Blocks: 739953, 584498, 846801, 846802    

Comment 5 Daniel Walsh 2011-09-28 11:44:08 EDT
So the bug here is in  /usr/share/dracut/modules.d/99base/selinux-loadpolicy.sh

to add -F to all calls of restorecon.
Comment 8 Daniel Walsh 2011-10-04 09:57:47 EDT
Why was a device in /dev labeled as something other then s0?
Comment 9 Alexander Todorov 2011-10-13 10:26:22 EDT
# grep restorecon selinux-loadpolicy.sh 
            LANG=C chroot "$NEWROOT" /sbin/restorecon -F -R /dev

# rpm -qf selinux-loadpolicy.sh 
dracut-004-247.el6.noarch


I see only one call to restorecon and -F parameter is added. Moving to VERIFIED.
Comment 10 errata-xmlrpc 2011-12-06 11:48:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1521.html