Bug 741550

Summary: Duplicate PV found after upgrade rhevh via RHEVM UI.
Product: Red Hat Enterprise Linux 6 Reporter: Guohua Ouyang <gouyang>
Component: ovirt-nodeAssignee: Mike Burns <mburns>
Status: CLOSED WORKSFORME QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2CC: apevec, cshao, gouyang, kli, leiwang, moli, ovirt-maint, ycui
Target Milestone: rcKeywords: TestOnly
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-05 01:59:54 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
vdsm.log none

Description Guohua Ouyang 2011-09-27 05:15:36 EDT
Created attachment 525062 [details]
vdsm.log

Description of problem:
Duplicate PV found after upgrade rhevh from 6.2-0.16.2 to 6.2-0.17.2 via RHEVM UI.  

# pvs
  Found duplicate PV UWC1St9iJI3jm1N5OZGUfJjScxdZi91N: using /dev/mapper/1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193p3 not /dev/mapper/1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193p3
  PV                                                       VG     Fmt  Attr PSize   PFree
  /dev/mapper/1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193p3 HostVG lvm2 a-   297.61g    0

# ll /dev/mapper/
total 0
brw-rw----. 1 root disk 253,  0 2011-09-27 15:34 1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193
brw-rw----. 1 root disk 253,  2 2011-09-27 15:34 1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193
brw-rw----. 1 root root 253,  1 2011-09-27 15:34 1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193p1
brw-rw----. 1 root disk 253,  9 2011-09-27 15:34 1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193p1
brw-rw----. 1 root disk 253, 10 2011-09-27 15:34 1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193p2
brw-rw----. 1 root root 253,  3 2011-09-27 15:34 1ATA     WDC WD3200AAKS-75L9A0                        WD-WMAV27854193p3
brw-rw----. 1 root disk 253, 11 2011-09-27 15:34 1ATA_WDC_WD3200AAKS-75L9A0_WD-WMAV27854193p3
crw-rw----. 1 root root  10, 58 2011-09-27 15:34 control
brw-rw----. 1 root disk 253,  6 2011-09-27 15:34 HostVG-Config
brw-rw----. 1 root disk 253,  8 2011-09-27 15:34 HostVG-Data
brw-rw----. 1 root disk 253,  7 2011-09-27 15:34 HostVG-Logging
brw-rw----. 1 root disk 253,  5 2011-09-27 15:34 HostVG-Swap


Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.17.2

How reproducible:
Always.

Steps to reproduce:
1.  install rhev-h-6.2-0.16.2
2.  configure network and register to rhevm
3.  approve rhevh in rhevm.
4.  after it show up, maintenance rhevh host
5.  upgrade rhev-h to 6.2-0.17.2 on rhevm UI.
6.  after reboot, login.
7.  drop to shell, run pvs

Actual results:
Duplicate PV found after upgrade rhevh via RHEVM UI.

Expected results:
no duplicate PV. 

Additional info:
without register to rhevm, upgrage with local media have no this issue.
Comment 1 Guohua Ouyang 2011-09-27 05:17:08 EDT
not sure it's vdsm's issue or ovirt-node's, please review and help assign if needed.
Comment 3 Alan Pevec 2011-09-27 09:08:41 EDT
One PV is original w/o spaces, the other one has spaces replaced with _
In the past we had seen this with udev rule creating entries with _ but it was supposed to be removed since rhevh 6.1 - bug 633222
Comment 4 Perry Myers 2012-01-03 13:55:41 EST
Can QE retest this with upgrading from RHEVH 6.2 GA to RHEVH 6.2 GA Update 1?  We don't think this issue should exist anymore, but would like QE to reverify
Comment 5 Guohua Ouyang 2012-01-05 01:04:49 EST
(In reply to comment #4)
> Can QE retest this with upgrading from RHEVH 6.2 GA to RHEVH 6.2 GA Update 1? 
> We don't think this issue should exist anymore, but would like QE to reverify

Yes, upgrade from RHEVH 6.2 GA (20111117) to RHEVH 6.2 GA Update1 (20111215) via RHEVM UI, have no this issue. It's must been fixed somewhere else.