Bug 741770

Summary: [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channel\xffffffff/4
Product: [Fedora] Fedora Reporter: Steve <bugzilla>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, leigh123linux, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-05 19:11:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
/var/log/gdm/\:0-greeter.log
none
/var/log/gdm/\:0-slave.log none

Description Steve 2011-09-27 16:23:00 EDT
Description of problem:
I can see the login-screen but not the login-box (see picture)

http://imageshack.us/photo/my-images/827/img2847resized.jpg/

dmesg shows:
[drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channel\xffffffff/4

Version-Release number of selected component (if applicable):
gdm-3.1.92-1.fc16.x86_64
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 leigh scott 2011-09-29 06:43:15 EDT
I have the same issue using the nvidia driver.

http://forums.fedoraforum.org/showthread.php?p=1515683
Comment 2 Greg` 2011-09-29 06:50:49 EDT
i get the same problem , just that i can log into XFCE and KDE, just not Gnome
Comment 3 Steve 2011-09-30 02:30:19 EDT
This bug is not fixed in gdm-3.2.0-1.fc16. Same error, can't login to gnome.
Comment 4 Greg` 2011-09-30 03:05:35 EDT
still not fixed for me either . ( just did the Gnome 3.2.0 update )
Comment 5 Adam Williamson 2011-09-30 14:47:52 EDT
I don't think this has anything to do with DRM or the graphics driver, I think it's more likely simply a bug in gdm.

Can you set Enable=true in the [debug] section of /etc/gdm/custom.conf try to log in, reproduce, then attach /var/log/gdm/\:0-greeter.log and /var/log/gdm/\:0-slave.log ? Thanks!
Comment 6 Steve 2011-09-30 15:58:35 EDT
Created attachment 525825 [details]
/var/log/gdm/\:0-greeter.log

There is no way to log-in because there is no log-in-dialogue (See the picture in Comment 0).
Comment 7 Steve 2011-09-30 15:59:02 EDT
Created attachment 525826 [details]
/var/log/gdm/\:0-slave.log
Comment 8 Steve 2011-10-03 07:22:41 EDT
I have installed 16-Beta.RC4 (29-Sep-2011) and gdm is working fine. Can someone confirm this?

gdm-3.2.0-1.fc16.x86_64
Comment 9 Greg` 2011-10-03 18:57:10 EDT
(In reply to comment #8)
> I have installed 16-Beta.RC4 (29-Sep-2011) and gdm is working fine. Can someone
> confirm this?
> 
> gdm-3.2.0-1.fc16.x86_64

mine still doesnt work right, only logs me into Gnome on a 2nd time.
Comment 10 Greg` 2011-10-05 19:02:47 EDT
mine works fine now