Bug 743509

Summary: [RFE] implement a script for joining to the Active Directory domain
Product: Red Hat Enterprise Linux 7 Reporter: Ondrej Valousek <ondrejv>
Component: sssdAssignee: Jakub Hrozek <jhrozek>
Status: CLOSED NEXTRELEASE QA Contact: Kaushik Banerjee <kbanerje>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.0CC: dpal, grajaiya, jgalipea, prc, sgallagh
Target Milestone: rcKeywords: FutureFeature
Target Release: 7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-18 13:02:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ondrej Valousek 2011-10-05 07:52:52 UTC
Right now we have a script to join a machine to the IPA domain.
We should have a similar script to join a machine to Active Directory domain.
It should do the similar tasks - i.e.:
1. configure /etc/samba/smb.conf
2. net ads join (- just to get machine creds in /etc/krb5.keytab)
3. configure sssd.conf to have something like this:

ldap_search_base = <search base>
id_provider = ldap
auth_provider = krb5
chpass_provider = krb5
cache_credentials = True
ldap_sasl_authid = <hostname>$@<REALM>
dns_discovery_domain = <REALM>
krb5_realm = <REALM>
ldap_sasl_mech = GSSAPI
ldap_user_object_class = user
ldap_group_object_class = group
ldap_user_home_directory = unixHomeDirectory
ldap_tls_cacertdir = /etc/openldap/cacerts
ldap_schema = rfc2307bis

4. configure PAM modules for sssd
5. configure /etc/krb5.conf
 
Does it make any sense?

Comment 2 RHEL Product and Program Management 2011-10-05 08:09:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Stephen Gallagher 2011-10-05 12:22:27 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1033

Comment 7 Jenny Severance 2013-03-18 13:02:51 UTC
Closing RFE, this was implemented by introducing realmd in RHEL 7.0