Bug 743619

Summary: Can't import Fedora 16
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: cobblerAssignee: James C. <jimi>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: awood, dgoodwin, maxamillion, mteixeira, redhat, shenson, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-16 20:54:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kamil Páral 2011-10-05 10:35:24 EDT
Description of problem:
I am completely new to cobbler. I was running according to:
https://fedorahosted.org/cobbler/wiki/UsingCobblerImport

I mounted and tried to import Fedora 16 Beta i386 DVD ISO.

It failed with this exception:

received on stderr: 
associating kickstarts
scanning /var/www/cobbler/ks_mirror/F16Beta_i386/images/pxeboot for distro signature
scanning /var/www/cobbler/ks_mirror/F16Beta_i386/images for distro signature
scanning /var/www/cobbler/ks_mirror/F16Beta_i386 for distro signature
found content (breed=redhat) at /v
Exception occured: <class 'cobbler.cexceptions.CX'>
Exception value: '--os-version for breed redhat must be one of rhel2.1, rhel3, rhel4, rhel5, rhel6, fedora5, fedora6, fedora7, fedora8, fedora9, fedora10, fedora11, fedora12, fedora13, fedora14, fedora15, generic24, generic26, virtio26, other, given was fedora16'
Exception Info:
  File "/usr/lib/python2.7/site-packages/cobbler/remote.py", line 95, in run
    rc = self._run(self)
   File "/usr/lib/python2.7/site-packages/cobbler/remote.py", line 225, in runner
    self.logger
   File "/usr/lib/python2.7/site-packages/cobbler/api.py", line 659, in import_tree
    return importer.run()
   File "/usr/lib/python2.7/site-packages/cobbler/action_import.py", line 227, in run
    self.kickstart_finder(distros_added)
   File "/usr/lib/python2.7/site-packages/cobbler/action_import.py", line 300, in kickstart_finder
    distro.set_os_version(version)
   File "/usr/lib/python2.7/site-packages/cobbler/item_distro.py", line 174, in set_os_version
    return utils.set_os_version(self,os_version)
   File "/usr/lib/python2.7/site-packages/cobbler/utils.py", line 1258, in set_os_version
    raise CX(_("--os-version for breed %s must be one of %s, given was %s") % (self.breed, nicer, os_version))

!!! TASK FAILED !!!


Version-Release number of selected component (if applicable):
cobbler-2.0.11-2.fc15.noarch
Comment 1 Robert Hoekstra 2011-11-10 11:04:02 EST
Same here for the final release.
Comment 2 Fedora Admin XMLRPC Client 2012-04-11 18:00:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 James C. 2012-04-16 20:54:54 EDT
This works as of the 2.2.0 release. If you continue to have issues with imports of F16, please open a new issue via the github issue tracker: https://github.com/cobbler/cobbler/issues
Comment 4 James C. 2012-04-16 20:57:10 EDT
*** Bug 751256 has been marked as a duplicate of this bug. ***