Bug 743652

Summary: pushing ec2 images throws JEOS mismatch error
Product: [Retired] CloudForms Cloud Engine Reporter: wes hayutin <whayutin>
Component: imagefactoryAssignee: Ian McLeod <imcleod>
Status: CLOSED DUPLICATE QA Contact: wes hayutin <whayutin>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 1.0.0CC: akarol, dajohnso, deltacloud-maint, dgao, ssachdev
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-05 20:10:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description wes hayutin 2011-10-05 16:10:07 UTC
Description of problem:
[root@unused ~]# rpm -Uvh http://repos.fedorapeople.org/repos/aeolus/imagefactory/0.7.0/packages/fedora-14/noarch/imagefactory-jeosconf-ec2-fedora-0.1.0-1.fc14.noarch.rpm
Retrieving http://repos.fedorapeople.org/repos/aeolus/imagefactory/0.7.0/packages/fedora-14/noarch/imagefactory-jeosconf-ec2-fedora-0.1.0-1.fc14.noarch.rpm
Preparing...                ########################################### [100%]
   1:imagefactory-jeosconf-e########################################### [100%]
[root@unused ~]# aeolus-restart-services 

Stoping ntpd ...
 Success: Stopping ntpd (via systemctl):                   [  OK  ]

Stoping imagefactory ...
 Success: Stopping imagefactory (via systemctl):           [  OK  ]

Stoping conductor-dbomatic ...
 Success: Stopping conductor-dbomatic (via systemctl):     [  OK  ]

Stoping aeolus-conductor ...
 Success: Stopping aeolus-conductor (via systemctl):       [  OK  ]

Stoping libvirtd ...
 Success: Stopping libvirtd (via systemctl):               [  OK  ]

Stoping deltacloud-core ...
 Success: Stopping deltacloud-core (via systemctl):        [  OK  ]

Stoping qpidd ...
 Success: Stopping qpidd (via systemctl):                  [  OK  ]

Stoping httpd ...
 Success: Stopping httpd (via systemctl):                  [  OK  ]

Stoping postgresql ...
 Success: Stopping postgresql (via systemctl):             [  OK  ]

Stoping iwhd ...
 Success: Stopping iwhd (via systemctl):                   [  OK  ]

Stoping mongod ...
 Success: Stopping mongod (via systemctl):                 [  OK  ]

Starting mongod ...
 Success: Starting mongod (via systemctl):                 [  OK  ]

Starting iwhd ...
 Success: Starting iwhd (via systemctl):                   [  OK  ]

Starting postgresql ...
 Success: Starting postgresql (via systemctl):             [  OK  ]

Starting httpd ...
 Success: Starting httpd (via systemctl):                  [  OK  ]

Starting qpidd ...
 Success: Starting qpidd (via systemctl):                  [  OK  ]

Starting deltacloud-core ...
 Success: Starting deltacloud-core (via systemctl):        [  OK  ]

Starting libvirtd ...
 Success: Starting libvirtd (via systemctl):               [  OK  ]

Starting aeolus-conductor ...
 Success: Starting aeolus-conductor (via systemctl):       [  OK  ]

Starting conductor-dbomatic ...
 Success: Starting conductor-dbomatic (via systemctl):     [  OK  ]

Starting imagefactory ...
 Success: Starting imagefactory (via systemctl):           [  OK  ]

Starting ntpd ...
 Success: Starting ntpd (via systemctl):                   [  OK  ]

Statusing mongod ...
 Success: mongod.service - SYSV: Starts and stops the MongDB daemon that handles all database requests.
	  Loaded: loaded (/etc/rc.d/init.d/mongod)
	  Active: active (running) since Wed, 05 Oct 2011 11:59:54 -0400; 12s ago
	 Process: 21695 ExecStop=/etc/rc.d/init.d/mongod stop (code=exited, status=0/SUCCESS)
	 Process: 21715 ExecStart=/etc/rc.d/init.d/mongod start (code=exited, status=0/SUCCESS)
	Main PID: 21726 (mongod)
	  CGroup: name=systemd:/system/mongod.service
		  └ 21726 /usr/bin/mongod --quiet -f /etc/mongodb.conf run
[root@unused ~]# aeolus-image build --target ec2 --template RHEL61.tpl 
Target Image: 6707ba85-c340-4089-8e4e-b1a940362084
Image: 70eb04b2-484a-4fd8-9255-a10e271cfcb8
Build: b893c9cd-19ff-4f74-b470-5c072dcd538d
Status: COMPLETED
Percent Complete: 100
[root@unused ~]# aeolus-image push --provider ec2-us-east-1 --id 70eb04b2-484a-4fd8-9255-a10e271cfcb8

Provider Image: 991647c0-0ee6-4fa5-938b-203b60480bbc
Image: 70eb04b2-484a-4fd8-9255-a10e271cfcb8
Build: b893c9cd-19ff-4f74-b470-5c072dcd538d
Status: FAILED
Percent Complete: 0
[root@unused ~]# cat /root/RHEL61.tpl 
<template>
  <name>RHEL_westest01</name>
  <os>    
    <name>RHEL-6</name>    
    <version>1</version>
    <arch>x86_64</arch>
    <rootpw>dog8code</rootpw>
    <install type="url">
      <url>http://download.devel.redhat.com/released/RHEL-6-Server/6.1/x86_64/os/</url>
    </install>
  </os>
  <description>RHEL61 x86_64 </description>
</template>
[root@unused ~]# 


2011-10-05 12:02:05,044 DEBUG imgfac.BuildJob.BuildAdaptor pid(22028) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from NEW to PUSHING
2011-10-05 12:02:05,045 DEBUG imgfac.BuildJob.BuildAdaptor pid(22028) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed percent complete from 0 to 0
2011-10-05 12:02:05,045 DEBUG imgfac.BuildJob.BuildAdaptor pid(22028) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from PUSHING to FAILED
2011-10-05 12:02:05,046 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(22028) Message: Exception caught in ImageFactory
2011-10-05 12:02:05,046 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(22028) Message: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 432, in push_image
    credentials)
  File "/usr/lib/python2.7/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 532, in push_image_snapshot_ec2
    raise ImageFactoryException("No available JEOS for desired OS, verison combination")
ImageFactoryException: No available JEOS for desired OS, verison combination

2011-10-05 12:02:05,047 DEBUG imgfac.BuildJob.BuildAdaptor pid(22028) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from FAILED to FAILED
[root@unused ~]#

Comment 1 jrd 2011-10-05 20:04:45 UTC
Ian?

Comment 2 wes hayutin 2011-10-05 20:10:54 UTC

*** This bug has been marked as a duplicate of bug 740622 ***