Bug 744420

Summary: cannot sign in with userlist
Product: [Fedora] Fedora Reporter: Marcus Moeller <marcus.moeller>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, cbm, cra, rstrode, sandro
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-20 15:17:09 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713568    

Description Marcus Moeller 2011-10-08 11:19:50 EDT
After upgrading to the latest packages from updates-testing today, i can no longer sign in, using the userlist in GDM.

I can select the username and enter the password, but when clicking on Sign In, nothing happens.

I have to choose 'not-listed' and enter my username manually.

gdm-3.2.0-2.fc16.x86_64

Besides that, language settings are now ignored and always fall back to English.
Comment 1 Colin Macdonald 2011-10-13 07:27:33 EDT
I think I can reproduce this---at least part of it.

gdm-3.2.0-2.fc16-i686

For me, I can log in the first time but then gnome-shell gives the "oh no, ..., logout" black screen (I'm trying to track down this bug separately.)  When I click logout, I'm returned to the GDM screen.

I can then select a user, type in the password but neither Enter nor clicking "sign in" work (the button animates a click but nothing happens, the password field is still filled in).

Clicking "cancel" returns me to the list of users.  I haven't tried "not-listed" so can't confirm that.  Nor can I confirm the ignoring of language settings.
Comment 2 Marcus Moeller 2011-10-18 07:49:24 EDT
It only seems to occur if a fingerprint reader is present.
Comment 3 Marcus Moeller 2011-10-18 08:13:33 EDT
Sorry, have to revert this. It also occurred on systems without fingerprint readers. The issue seems to be fixed by: gnome-settings-daemon-3.2.1-1.fc16
Comment 4 Sandro Mathys 2011-10-20 12:14:33 EDT
I've seen this issue a couple of times and can confirm the mentioned update is a valid fix:
https://admin.fedoraproject.org/updates/FEDORA-2011-14510

Blocking F16Blocker; proposing as a blocker because this clearly breaks the desktop login test case:
https://fedoraproject.org/wiki/QA:Testcase_desktop_login
Comment 5 Adam Williamson 2011-10-20 12:35:34 EDT
May be a dupe of 740625?
Comment 6 Charles R. Anderson 2011-10-20 15:17:09 EDT

*** This bug has been marked as a duplicate of bug 740625 ***
Comment 7 Colin Macdonald 2011-10-21 00:12:45 EDT
Hmmm, well I still observe this issue with

> Installed Packages
> gnome-settings-daemon.i686          3.2.1-1.fc16           @updates-testing
Comment 8 Adam Williamson 2011-10-21 00:43:26 EDT
colin, your bug does not appear to be the same thing. please  file it separately.
Comment 9 Colin Macdonald 2011-10-23 06:30:28 EDT
Maybe so, but this update seems to have fixed it.  I won't bother opening a new bug, unless I see it again.

===========================================================================================================================
 Package                 Arch                     Version                                 Repository                  Size
===========================================================================================================================
Installing:
 gdm                     i686                     1:3.2.1.1-1.fc16                        fedora                     1.1 M
     replacing  gdm-plugin-fingerprint.i686 1:3.2.0-2.fc16