Bug 7445

Summary: bash2 and xemacs, error in font-lock-fontify-buffer
Product: [Retired] Red Hat Powertools Reporter: santini
Component: xemacsAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-08 19:08:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch to work-around the problem none

Description santini 1999-11-30 15:45:11 UTC
RedHat has chosen to call the bash2 the new bash v2.x (to reduce downwards
compatibility problems?) thus introducing some little problem here and
there :-)

One of this is the "fontify"-cation of shell files in xemacs, which
results in all sort of strange errors (no file is opened at all, if
fontifycation is by default!). The reason seems to be that the elisp code
looks at the SHELL env variable to determine the correct fontifycation
style, and bash2 is not considered as a correct shell.

Suggestion: export SHELL=/bin/bash, but even better: why not throwing away
the old bash and using the v2.x?

	Massimo

Comment 1 Tim Powers 1999-11-30 16:13:59 UTC
We would love to throw away the old bash and just use the new, but at the time
there were (and still are) issues with old bash scripts not working with bash2.

Just out of curiosity, when you do this "SHELL=/bin/bash" is the problem fixed?

Tim

Comment 2 fortytwo 1999-12-10 06:02:59 UTC
Changing $SHELL to "/bin/bash" works.  Since it's such a simple problem, xemacs
is ready for the fix.  :)

In xemacs, Menuitem
Options->Customize->Emacs->Programming->Languages->Sh->Ancestor Alist

Click on the [INS] at the end and fill in

------
[INS] [DEL] Cons-cell:
            Symbol: bash2
            Symbol: bash
------

Patch to follow.

Comment 3 fortytwo 1999-12-10 06:10:59 UTC
Created attachment 38 [details]
Patch to work-around the problem

Comment 4 Ngo Than 2000-02-08 19:08:59 UTC
apply the patch to xemacs