Bug 744534

Summary: Nautilus can't start when nautilus-terminal is installed
Product: [Fedora] Fedora Reporter: Simone Tolotti <simone.tolotti>
Component: nautilus-terminalAssignee: Hicham HAOUARI <hicham.haouari>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: adrigiga, alexl, chat-to-me, fedora-fr, hicham.haouari, jung_cedric, loganjerry, madko, mfohler, nsp_rhbug, rockowitz, samuel-rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: nautilus-python-1.1-2.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-20 20:27:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
coredump with nautilus-python 1.1 (reply 12) none

Description Simone Tolotti 2011-10-09 05:42:49 EDT
I receive this error when trying to start Nautilus after installing nautilus-terminal package:
Gtk-Message: Failed to load module "pk-gtk-module"
(nautilus:5016): Tracker-DEBUG: Initializing tracker-tags extension

Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))

(nautilus:5016): Nautilus-Python-WARNING **: nautilus_python_init_python failed
Traceback (most recent call last):
  File "/usr/share/nautilus-python/extensions/nautilus_terminal.py", line 48, in <module>
    from gi.repository import Nautilus, Gtk, Gdk, Vte, GLib
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: cannot import name _API



Version-Release number of selected component (if applicable):
nautilus-terminal 1.0-0.1.8bzrfc16

How reproducible:
Install package and run nautilus

Steps to Reproduce:
1.
2.
3.
  
Actual results:
nautilus can't start

Expected results:
nautilus starts

Additional info:
Comment 1 Wolfgang Ulbrich 2011-10-19 12:40:48 EDT
(In reply to comment #1)
> Can you please show me the configuration of the plugin?
> 
> $ cat ~/.config/xfce4/panel/genmon-*.rc

[rave@mother ~]$ cat ~/.config/xfce4/panel/genmon-*.rc
Command=sh /home/rave/Shell-scripte/CPU-Frequenz.sh
UseLabel=1
Text=CPU-Freq
UpdatePeriod=5000
Font=(default)

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa0-0.sh
UseLabel=1
Text=Temp twa0-0
UpdatePeriod=30000
Font=Sans 10

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa0-1.sh
UseLabel=1
Text=Temp twa0-1
UpdatePeriod=30000
Font=(default)

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa0-2.sh
UseLabel=1
Text=Temp twa0-2
UpdatePeriod=30000
Font=(default)

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa0-3.sh
UseLabel=1
Text=Temp twa0-3
UpdatePeriod=30000
Font=(default)

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa1-0.sh
UseLabel=1
Text=Temp twa1-0
UpdatePeriod=30000
Font=(default)

Command=sh /home/rave/Shell-scripte/Temp-3ware-twa1-0.sh
UseLabel=1
Text=Temp twa1-1
UpdatePeriod=30000
Font=(default)

(In reply to comment #2)
> BTW, please try this update:
> https://admin.fedoraproject.org/updates/xfce4-genmon-plugin-3.3.0-3.fc15

Thx for fixing, with that version everthing works fine.
Comment 2 Wolfgang Ulbrich 2011-10-19 12:46:31 EDT
sorry for my last comment, sometimes redhat bugzilla insert old comments from me :(
Comment 3 FLOZz 2011-11-02 05:45:18 EDT
Hello,

With Nautilus 3.2, Nautilus Python need to be upgraded to the version 1.1
Comment 4 Hicham HAOUARI 2011-11-02 06:36:39 EDT
(In reply to comment #3)
> Hello,
> 
> With Nautilus 3.2, Nautilus Python need to be upgraded to the version 1.1

Thanks FLOZz for helping us. I will update nautilus-python to 1.1 ASAP.
Comment 5 Hicham HAOUARI 2011-11-07 16:22:51 EST
*** Bug 751872 has been marked as a duplicate of this bug. ***
Comment 6 cedric 2011-11-15 12:13:27 EST
I add my wish for nautilus-python 1.1; I don't manage to build it locally.
Thanks,
C
Comment 7 Wolfgang Ulbrich 2011-11-15 18:42:21 EST
I 've build a rpm of nautilus-python with nautilus-python 1.1 and also rebuild nautilus-terminal under fc16, but it doesn't helped.
I get this error message when i try to start nautilus and the plugin isn't load.

Initializing nautilus-search-tool extension
Initializing nautilus-gdu extension
Initializing nautilus-image-converter extension
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))

Nov 16 00:38:52 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 00:38:52 mother abrt: [N-A] Nautilus-Actions Tracker 3.1.3 initializing...

But i find no report in abrt.
Comment 8 FLOZz 2011-11-16 05:33:01 EST
> and also rebuild nautilus-terminal under fc16, but it doesn't helped.

From the upstream released tarball ?
Comment 9 Wolfgang Ulbrich 2011-11-16 07:52:30 EST
No, i rebuild the current fc16 release of nautilus-terminal.
But, then i remove the current release, an installed nautilus-terminal_1.0_src.tar.gz by hand. Is that the tarball you mean?
Comment 10 Wolfgang Ulbrich 2011-11-16 09:01:59 EST
To put it more clearly, with nautilus-python-1.1-1.fc16.x86_64 and the installation of the latest tarball nautilus-terminal_1.0_src.tar.gz by hand, nautilus starts already, but i get this error messge and the plugin isn't load.

nautilus version is nautilus-3.2.1-2.fc16.x86_64.
Comment 11 Wolfgang Ulbrich 2011-11-16 09:46:15 EST
Ok,
this error message only appears when i used the xfce desktop.

Initializing nautilus-search-tool extension
Initializing nautilus-gdu extension
Initializing nautilus-image-converter extension
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in
<module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using
gi.repository you must not import static modules like "gobject". Please change
all occurrences of "import gobject" to "from gi.repository import GObject".',))

If i used the gnome-3.2 desktop i see no error message in the terminal, but i see this in /var/log/messages

Nov 16 15:31:55 mother nautilus: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 15:31:55 mother abrt: detected unhandled Python exception in 'nautilus'
Comment 12 Wolfgang Ulbrich 2011-11-16 11:39:47 EST
New Info's:
I gnome3 in a terminal.

Initializing nautilus-search-tool extension
Initializing nautilus-gdu extension
Initializing nautilus-image-converter extension
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))

/var/spool/abrt/ccpp-2011-11-16-17:23:24-3412/var_log_messages

Nov 16 17:10:14 mother nautilus: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:10:14 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:10:48 mother nautilus-su: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:10:48 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:16:34 mother nautilus: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:16:34 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:16:45 mother nautilus-su: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:16:45 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:18:35 mother nautilus-su: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:18:35 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:19:03 mother nautilus: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:19:03 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:19:17 mother nautilus-su: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:19:17 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:19:47 mother nautilus: [N-A] Nautilus-Actions Menu Extender 3.1.3 initializing...
Nov 16 17:19:47 mother abrt: detected unhandled Python exception in 'nautilus'
Nov 16 17:23:24 mother kernel: [  851.786634] nautilus[3412] trap divide error ip:39a8632b5c sp:7fff8b79ea60 error:0 in libglib-2.0.so.0.3000.1[39a8600000+11e000]
Nov 16 17:23:25 mother abrt[3758]: Saved core dump of pid 3412 (/usr/bin/nautilus) to /var/spool/abrt/ccpp-2011-11-16-17:23:24-3412 (81371136 bytes)

[root@mother rave]# cat /var/spool/abrt/ccpp-2011-11-16-17\:23\:24-3412/reason 
Process /usr/bin/nautilus was killed by signal 8 (SIGFPE)

[root@mother rave]# cat /var/spool/abrt/ccpp-2011-11-16-17\:23\:24-3412/component 
nautilus

Do you need more info'from /var/spool/abrt/ccpp-2011-11-16-17\:23\:24-3412 ?
Comment 13 Jerry James 2011-11-17 10:28:28 EST
This bug may be the cause of bug 743480.
Comment 14 Alex Lancaster 2011-11-20 01:11:49 EST
I can confirm that presence of nautilus-terminal, prevents nautilus starting with error as described in comment #12, above.
Comment 15 Wolfgang Ulbrich 2011-11-21 06:06:25 EST
Created attachment 534760 [details]
coredump with nautilus-python 1.1 (reply 12)
Comment 16 mfohler 2011-11-21 12:34:37 EST
For me the same, like comment #14 said. Happens also with the version directly installed from source downloaded from nautilus-terminal website.
Comment 17 sanford rockowitz 2011-11-21 23:43:42 EST
Similar problem in fc 16, with similar error messages seen in .xsession-errors.  Using gnome in fallback mode.  The desktop doesn't appear.  Installing nautilus-terminal-1.0-0.1.8bzr.fc16 causes the problem, and removing it resolves the problem.
Comment 18 Edouard Bourguignon 2011-12-31 05:02:15 EST
Same problem with any python extension for nautilus that tries to import GObject from gi.repository.
Any news?
Comment 19 mfohler 2012-01-23 04:34:10 EST
I just tried again nautilus-terminal (my nautilus-python is still version 1.0 !) and now nautilus starts without an error with the plugin installed. But now the plugin doesn't work anymore, can't see the terminal inside the nautilus window. Tried it with the version from repository and with the version from the official website: http://projects.flogisoft.com/nautilus-terminal/ Same behavior for both versions.
Comment 20 Fedora Update System 2012-02-16 04:13:26 EST
nautilus-python-1.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nautilus-python-1.1-2.fc16
Comment 21 mfohler 2012-02-16 09:17:13 EST
Related to this bug here is a report on the native plugin site: https://bugs.launchpad.net/nautilus-terminal/+bug/920268

I installed the updates for nautilus-python and nautilus-terminal from post 7 (https://bugs.launchpad.net/nautilus-terminal/+bug/920268/comments/7) and then the new update for nautilus-python from post 10 (https://bugs.launchpad.net/nautilus-terminal/+bug/920268/comments/10), also I think the first nautilus-python update is not necessary anymore. Now everthing works fine! Thanks a lot to the developers!
Comment 22 Fedora Update System 2012-02-16 19:56:24 EST
Package nautilus-python-1.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nautilus-python-1.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1864/nautilus-python-1.1-2.fc16
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2012-02-20 10:42:24 EST
nautilus-python-1.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nautilus-python-1.1-2.fc17
Comment 24 Fedora Update System 2012-02-20 20:27:05 EST
nautilus-python-1.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2012-02-28 05:52:05 EST
nautilus-python-1.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.