Bug 744763

Summary: After the lock of screen the unlock prompt is shown immediately.
Product: Red Hat Enterprise Linux 6 Reporter: Lukas Zachar <lzachar>
Component: gnome-screensaverAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2CC: aakkiang, jkoten, psplicha, tpelka
Target Milestone: rcKeywords: OtherQA, Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-screensaver-2.28.3-22.el6 Doc Type: Bug Fix
Doc Text:
Cause: Mouse cursor can be moved to non-primary monitor Consequence: unlock dialog doesn't come up when giggling mouse on non-primary monitor Fix: prevent mouse cursor from being moved to non-primary monitor Result: unlock dialog comes up anytime mouse is moved
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 05:07:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 840699    

Comment 8 Asha Akkiangady 2011-11-04 17:42:18 EDT
Logged into RHEL-6.2 desktop with a smart card and locked screen using the menu option. When smart card is removed and re-inserted on a locked screen, the events are not reported, a smart card removal event should prompt the user to insert the particular smart card used to lock the screen and a smart card insertion should detect the smartcard cert validity and prompt for a pin. 

Currently the messages on the screen does not change, displays welcome username and a request to enter smart card pin. 

Tested this with -15 (gnome-screensaver-2.28.3-15.el6), -16 and -17, same problem is observed. Looks like the issue is related to this bug 744763.
Comment 9 Suzanne Yeghiayan 2012-05-29 15:35:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release.
Comment 12 Ray Strode [halfline] 2012-08-09 13:39:58 EDT
devack+
Comment 18 errata-xmlrpc 2013-02-21 05:07:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0390.html