Bug 745661

Summary: login sets only one group ignoring /etc/group /etc/gshadow
Product: [Fedora] Fedora Reporter: Barry Fishman <barry_fishman>
Component: distributionAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact: Bill Nottingham <notting>
Severity: high Docs Contact:
Priority: urgent    
Version: 16CC: dennis, rebus, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=745675
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 745675 Environment:
Last Closed: 2011-10-12 22:18:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Barry Fishman 2011-10-12 19:14:18 EDT
Description of problem:
After upgrade on 2011-10-12, I found that when I log in I am only a
member of the group specified in /etc/password and not the other groups
specified in /etc/group /etc/gshadow

Version-Release number of selected component (if applicable):
Fedora 15


How reproducible:
True for all gdm and console login's I have tried

Steps to Reproduce:
1. Login on console or through gdm
2. Perform a 'id' or 'groups' command
   Or try changing group ownership of file to another group of which you are
   a member.

Actual results:

% grep barry /etc/group
wheel:x:10:root,barry
util:x:19:barry
ftp:x:50:barry
barry:x:500:barry

% grep barry /etc/passwd
barry:x:500:500:Barry Fishman:/home2/barry:/bin/bash
 
% id
uid=500(barry) gid=500(barry) groups=500(barry)

% groups
barry

% ls -dl .
drwxr-sr-x 2 barry barry 4096 Oct 12 19:04 .

% touch foo
% chgrp util foo
chgrp: changing group of `foo': Operation not permitted

Expected results:

% groups
wheel util ftp barry

Additional info:

% uname -a
Linux ecube.site 3.1.0-0.rc9.git0.0.fc16.x86_64 #1 SMP Wed Oct 5 15:30:54 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Michal Ambroz 2011-10-12 20:49:28 EDT
Same symptoms - Fedora 16 Beta i686
I just updated packaged using "yum -y update" and found that groups are not processed:

[root@mixer ~]# grep root /etc/group
root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
disk:x:6:root
wheel:x:10:root,mambroz
[root@mixer ~]# id root
uid=0(root) gid=0(root) groups=0(root)

Linux mixer.localdomain 3.1.0-0.rc9.git0.0.fc16.i686.PAE #1 SMP Wed Oct 5 15:51:55 UTC 2011 i686 i686 i386 GNU/Linux
Comment 2 Michal Ambroz 2011-10-12 22:18:37 EDT
Rebooting to old kernel didn't help so issue is most probably about glibc
upgraded from glibc-2.14.90-10 to glibc-2.14.90-11

This bug is most probably duplicate of bug #745675

*** This bug has been marked as a duplicate of bug 745675 ***