Bug 746879

Summary: Anaconda handles multiple displays poorly
Product: [Fedora] Fedora Reporter: Pete Travis <me>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: akozumpl, anaconda-maint-list, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-18 04:12:34 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pete Travis 2011-10-18 00:57:24 EDT
Description of problem:
With two LCD panels plugged into my nvidia card, anaconda used both displays but restricted the UI window to one.  The window seemed to be larger than the physical display, making the buttons to continue inaccessible.

Version-Release number of selected component (if applicable):


How reproducible:
Insert install DVD into a multi-head system and boot.
  
Actual results:
Configuration menus are too large to be fully viewed and interacted with

Expected results:
Anaconda sizes windows properly, or if dependencies are too bloated, anaconda defaults to using only one screen.

Additional info:
Unplugging one of the displays and starting over made it work fine.
Comment 1 Pete Travis 2011-10-18 00:58:03 EDT
[pete@thefool ~]$ lspci -s 05: -v
05:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce GTS 250] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: Micro-Star International Co., Ltd. Device 1543
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at ec00 [size=128]
	Expansion ROM at fcfe0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb
Comment 2 Pete Travis 2011-10-18 00:59:05 EDT
Whoops, lcpci posted for hardware reference, I didn't check to see if nouveau was in use during the install, but I can if needed.
Comment 3 Ales Kozumplik 2011-10-18 04:12:34 EDT

*** This bug has been marked as a duplicate of bug 725219 ***