Bug 747982

Summary: broken konqueror launcher
Product: [Fedora] Fedora Reporter: nucleo <alekcejk>
Component: kdebase-workspaceAssignee: Ngo Than <than>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: awilliam, fedora, jreznik, kevin, ltinkl, oliver.henshaw, rdieter, rnovacek, ry, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: kdebase-workspace-4.7.2-8.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-24 23:41:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713568    

Description nucleo 2011-10-21 11:32:57 EDT
Description of problem:
konqueror launcher (part of Task Manager widget) randomly starts konqueror as file manager or at next attempt to start as browser with error message "Improperly Formatted URL".

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start konqueror launcher.
2. Close konqueror.
3. Start konqueror launcher again.
Actual results:
Error: Improperly Formatted URL
The Uniform Resource Locator (URL) that you entered was not properly formatted. The format of a URL is generally as follows:

Expected results:
Konqueror should start as browser without errors. (not as file managed because there is file manager dolphin).
These launcher (konqueror and dolphin) is not configurable - if they removed then no way to restore them so maybe they should be removed because this new KDE 4.7 feature looks as not complete.

Additional info:
This happens for me on 16.TC2 LiveCD but for new user on installed F16 konqueror starts as file manager instead of as browser.
Comment 1 nucleo 2011-10-21 12:12:16 EDT
Launchers added in ~/.kde/share/config/plasma-desktop-appletsrc

browser=preferred://browser, , ,\s
filemanager=preferred://filemanager, , ,\s

after commit
Comment 2 Rex Dieter 2011-10-21 12:21:12 EDT
OK, I can semi-regularly reproduce this using the 16.TC2 i686 live image.

first launch of

kfmcilent openURL 'preferred://browser'

gives the error as reported.  without closing, all subsequent launched work.

interestingly (confirmed by nucleo on irc),
kfmcilent openURL 'preferred://filemanager' seems to also run konqueror (instead of dolphin as expected)
Comment 3 Rex Dieter 2011-10-21 12:55:39 EDT
I think we tentatively agreed on irc to revert the upstream change that introduced these preferred://-using launchers , given this bug, and the one about not being able to remove them.

So, while we're at it, let's get an upstream bug filed to track new issue (so we can consider dropping the reversion when both issues are known fixed)
Comment 4 Fedora Update System 2011-10-21 15:12:51 EDT
kdebase-workspace-4.7.2-8.fc16 has been submitted as an update for Fedora 16.
Comment 5 nucleo 2011-10-21 15:35:52 EDT
This bug is final release blocker because meets this release requirement:

14. All elements of the default panel configuration in all release-blocking desktops must function correctly in common use

One of launchers on default panel is broken.
Comment 6 Adam Williamson 2011-10-21 15:41:09 EDT
+1 blocker per comment #5.
Comment 7 Adam Williamson 2011-10-24 12:39:51 EDT
Discussed at the 2011-10-24 QA meeting functioning as a blocker review meeting. Accepted as a blocker bug per comment #5.

Fedora Bugzappers volunteer triage team
Comment 8 Oliver Henshaw 2011-10-24 19:17:06 EDT
(In reply to comment #2)
> OK, I can semi-regularly reproduce this using the 16.TC2 i686 live image.
> first launch of
> kfmcilent openURL 'preferred://browser'
Is kfmclient supposed to understand the preferred:// url? I thought it was only the tasks launcher that does.
Comment 9 Fedora Update System 2011-10-24 23:41:40 EDT
kdebase-workspace-4.7.2-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.