Bug 748747

Summary: Gstreamer-based apps don't display video when using software 3D rendering (clutter involved)
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: mesaAssignee: Adam Jackson <ajax>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: adel.gadllah, ajax, awilliam, bnocera, jdulaney, renault, tflink, xgarve
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mesa-7.11-8.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-29 02:30:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713568    
Attachments:
Description Flags
screenshot
none
screenshot inside VM of totem playing video none

Description Kamil Páral 2011-10-25 05:14:42 EDT
Created attachment 530035 [details]
screenshot

Description of problem:
This is a follow-up of bug 747276. After fixing totem startup, it still doesn't display video (the UI works, progress bar moves, just the video is not displayed). Tested in KVM. I'll re-test on bare metal.

Totem screen is usually black, once I saw a first frame of the video (but not moving).

Tested on http://download.blender.org/peach/trailer/trailer_400p.ogg

Version-Release number of selected component (if applicable):
mesa-dri-drivers-7.11-5.fc16.i686
mesa-dri-filesystem-7.11-5.fc16.i686
mesa-libGL-7.11-5.fc16.i686
mesa-libGLU-7.11-5.fc16.i686
totem-3.2.1-1.fc16.i686

How reproducible:
seems always, also adamw confirmed

Steps to Reproduce:
1. download video
2. run totem on it
Comment 1 Kamil Páral 2011-10-25 05:15:24 EDT
Proposing as blocker:

"All applications listed under the Applications
menu or category must withstand a basic functionality test and not crash after
a few minutes of normal use. They must also have working Help and Help -> About
menu items"
Comment 2 Kamil Páral 2011-10-25 06:59:28 EDT
Using bare metal machine and forced fallback mode (with nouveau driver), totem playback works.

Using bare metal machine and xdriver=vesa nomodeset kernel options, totem playback doesn't work, same symptoms as in KVM.
Comment 3 Adam Williamson 2011-10-25 11:41:32 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2011-10-25 15:56:12 EDT
Note that this also affects Cheese (you can't see video from your webcam) and Empathy (video chat fails) that we've discovered.

It's less of a straight-up obvious blocker than it was when everything was crashing, but still a big issue. I'm kind of on the fence over its blockeriness. Other votes?
Comment 5 Adel Gadllah 2011-10-25 16:07:12 EDT
(In reply to comment #4)
> Note that this also affects Cheese (you can't see video from your webcam) and
> Empathy (video chat fails) that we've discovered.
> 
> It's less of a straight-up obvious blocker than it was when everything was
> crashing, but still a big issue. I'm kind of on the fence over its
> blockeriness. Other votes?

There is only a cosmetic difference between "crashes" and "does not work" ... for the user the result is the same "can't use the software".

So not sure what your point is. So if the old bug is a blocker this one is as well.
Comment 6 Tim Flink 2011-10-25 16:11:31 EDT
I'm pretty much in the same boat Adam is on this one. Definitely +1 NTH but I'm not as sure about delaying release because videos don't play w/ mesa

Do we have any idea how hard this would be to fix?
Comment 7 Adam Williamson 2011-10-25 16:18:37 EDT
adel: the difference is cosmetic in the case of totem (although not entirely so, as you can at least use it to play music now), but it isn't in the case of empathy: before, empathy was entirely unusable, now, only video chat is broken.
Comment 8 Dennis Gilmore 2011-10-25 17:43:11 EDT
+1 blocker
Comment 9 Kamil Páral 2011-10-26 05:53:34 EDT
"Boot in safe graphics mode" uses vesa driver, and therefore this issue will be encountered every time user boots in safe graphics mode. I have seen countless systems myself where the only option to boot is to use safe graphics mode. Sometimes people even work in it for some time. Graphic drivers are a big pain in Linux.

Unless this takes too long to fix for some reason, I vote +1 blocker (which implies +1 nth if blocker is not accepted).
Comment 10 Adel Gadllah 2011-10-26 06:09:17 EDT
(In reply to comment #7)
> adel: the difference is cosmetic in the case of totem (although not entirely
> so, as you can at least use it to play music now),

Yeah but its primary use is playing videos.

> but it isn't in the case of
> empathy: before, empathy was entirely unusable, now, only video chat is broken.

Indeed. Cheese otoh is completely broken as well.
Comment 11 Adam Jackson 2011-10-27 10:08:45 EDT
I'm less interested in Cheese in a virtual machine.  And it's worth pointing out that this does not seem to affect baremetal installs.  So what we need to do is figure out whether this is a bug in the X driver in the guest, or in qemu itself.

Two things to test:

If you take a screenshot inside the guest while playing a video in totem (run gnome-screenshot(1) for instance), does the screenshot show the video correctly?

If using the vesa or cirrus drivers in the guest, does the behaviour differ if you enable ShadowFB in xorg.conf?  Example:

Section "Device"
    Identifier "vesa"
    Driver "vesa"
    Option "ShadowFB" "on"
EndSection
Comment 12 Adam Williamson 2011-10-27 11:58:37 EDT
"And it's worth pointing
out that this does not seem to affect baremetal installs."

Yes, it does. We've already tested that and  reported as much:

"Using bare metal machine and xdriver=vesa nomodeset kernel options, totem
playback doesn't work, same symptoms as in KVM."

Bare metal with a native driver in fallback mode works, but then, it would be odd if it didn't. The fact that you're using fallback mode alone doesn't mean your hardware 3D magically stops working. But if you use bare metal in a config where there's no hardware 3D, you hit this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Tim Flink 2011-10-27 12:03:10 EDT
Created attachment 530521 [details]
screenshot inside VM of totem playing video

I did a fresh x86_64 install of F16 in a VM.

When I take a screenshot inside the VM while a video is running, the part of the screen that is supposed to show the video is black.

When I enable ShadowFB for vesa as requested in comment 11, I get the same results - audio but the part of the screen containing the video part is black.
Comment 14 Adam Jackson 2011-10-27 13:19:28 EDT
(In reply to comment #12)
> "And it's worth pointing
> out that this does not seem to affect baremetal installs."
> 
> Yes, it does. We've already tested that and  reported as much:

Odd, could have sworn it worked on the machine I tested this on.
Comment 15 Adam Williamson 2011-10-27 13:30:45 EDT
For me it failed the same way it did for Tim, booting to vesa. I'll test with nouveau.noaccel, for giggles.
Comment 16 Adam Williamson 2011-10-28 01:53:05 EDT
with nouveau.noaccel, same fail. so it does seem like it just doesn't work unless you have 3D acceleration.
Comment 17 John Dulaney 2011-10-28 12:23:12 EDT
Ok, I decided to test for this, and I'm hitting this with nouveau.noaccel as well as vesa on both of my bare metal test boxen.  Oddly enough, I will also occasionally (probably 3 or 4% of the time) on my remaining F15 box (unless that's something else).  Of course, my F15 box is kept up-to-date.

I'm +1 for blocker.
Comment 18 John Dulaney 2011-10-28 12:25:09 EDT
BTW, when video on F15 acts up, restarting the X server seems to fix it.
Comment 19 Adam Williamson 2011-10-28 12:29:21 EDT
taking a shot at mesa, this is not a totem bug.
Comment 20 Adam Jackson 2011-10-28 20:36:52 EDT
Comedy.  clutter's using GLX_INTEL_swap_event now (and more power to it), which we enabled for both proper DRI2 drivers that can support it and for llvmpipe where we can't.  Oops.
Comment 21 Fedora Update System 2011-10-28 20:49:42 EDT
mesa-7.11-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mesa-7.11-8.fc16
Comment 22 Adam Williamson 2011-10-28 21:41:57 EDT
Fix looks good: I can play video in totem and record video and pictures from cheese when using qxl, nouveau or vesa. Playback of Big Buck Bunny OGG is a bit messy - garbage in the letterboxes, and it's a bit jerky - but it works.
Comment 23 Fedora Update System 2011-10-29 02:30:47 EDT
mesa-7.11-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Garve 2011-11-09 12:38:44 EST
Hi.

Maybe this helps you:
http://www.fedoraforum.org/forum/showthread.php?t=271942

"Probably unrelated but my totem and rhythmbox weren't working due to a gstreamer problem. I fixed it by deleting my .gstreamer-0.10 directory in home."

This solved everything for me.
Comment 25 Adam Williamson 2011-11-10 21:06:01 EST
that has nothing at all to do with this bug.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers