Bug 749549

Summary: Garbled screen output with openchrome
Product: Red Hat Enterprise Linux 6 Reporter: Alexander Todorov <atodorov>
Component: xorg-x11-drv-openchromeAssignee: Adam Jackson <ajax>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Desktop QE <desktop-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 6.2CC: atodorov, tpelka
Target Milestone: rcKeywords: OtherQA
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-05 14:56:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 960058, 749555, 840699    
Description Flags
login screen picture
picture of gnome desktop
xorg.conf none

Description Alexander Todorov 2011-10-27 09:34:50 EDT
Created attachment 530485 [details]
login screen picture

Description of problem:
On one of my laptops which uses openchrome video driver RHEL 6.2 screen looks garbled. Same does 6.1 too. 

Login window is not centred and bottom panel is missing, the screen is clearly readable. 

When I login into GNOME the screen is not readable. Main menu is shown 4-5 times repeatedly. 

See screenshots.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. # lspci  | grep VGA
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro] (rev 01)

2. Install RHEL 6.2 snap #4 Workstation i386
3. No xorg.conf, use auto config
4. Boot and login into GNOME.
Actual results:
Screen is not usable.

Expected results:
Everything works.

Additional info:
Comment 1 Alexander Todorov 2011-10-27 09:35:53 EDT
Created attachment 530486 [details]
picture of gnome desktop
Comment 3 Alexander Todorov 2011-10-27 09:38:54 EDT
Created attachment 530488 [details]

With this xorg.conf and changing driver to vesa I'm able to use my screen again.
Comment 4 Adam Jackson 2011-10-27 10:00:01 EDT
Not a regression, moving to 6.3.